mina-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeroen Brattinga" <jeroen.bratti...@gmail.com>
Subject Re: How to get SumUp example working using UDP?
Date Tue, 10 Oct 2006 09:24:26 GMT
I'm having troubles to get the snapshot from the repository (using Eclipse).
I keep getting messages that tell me to 'visit people.apache.org to log in
to your apache account'. But people.apache.org doesn't let me create (or log
in to) in account.

In short: what user/pass do I need to gain access to the repository. I can
get to it using a browser, but building from there would be very cumbersome.


Some more information: when I test the 1.0.0 SumUp example on my system at
work (that has the same Windows XP SP2 environment) with UDP, it waits
indefinitely on the future.join() call in the Client class. It doesn't do
that on my system at home...

I will look into this further tonight (in about 8 hours).

Kind regards,


Jeroen Brattinga


2006/10/10, Trustin Lee <trustin@gmail.com>:
>
> What version of MINA are you using?  If you are using 0.8.x, please
> upgrade
> to 1.0.1-SNAPSHOT.  You can build it from our source code repository:
>
> https://svn.apache.org/repos/asf/directory/branches/mina/1.0/
>
> Trustin
>
> On 10/9/06, Jeroen Brattinga <jeroen.brattinga@gmail.com> wrote:
> >
> > My exact environment is Windows XP SP2 (including latest patches), Java
> > 1.5_08, Eclipse 3.2
> >
> > In my first tests with the SumUp example I forgot that the sessionOpened
> > event doesn't fire for UDP sockets. After moving the AddMessage write
> loop I
> > stil get no result on the client. I also get some NullPointerExceptions
> on
> > the Server. But in my own application (that only uses the client side of
> the
> > SumUp example) I see the exact same behaviour: messages are sent
> > succesfully, but answers are never recieved.
> >
> > See the enclosed output for TCP and UDP runs.
> >
> > TIA,
> >
> > Jeroen
> >
> >
> > 2006/10/9, Trustin Lee <trustin@gmail.com>:
> > >
> > > Hi Jeroen,
> > >
> > > I replaced Socket to Datagram in Client and Server classes and tested
> in
> > > Ubuntu Linux 6.06.  The server and client exchanged data correctly
> > > although
> > > I found a bug:
> > >
> > > http://issues.apache.org/jira/browse/DIRMINA-283
> > >
> > > Let me know your exact environment if you are still experiencing this
> > > issue.
> > >
> > > HTH,
> > > Trustin
> > > --
> > > what we call human nature is actually human habit
> > > --
> > > http://gleamynode.net/
> > > --
> > > PGP key fingerprints:
> > > * E167 E6AF E73A CBCE EE41  4A29 544D DE48 FE95 4E7E
> > > * B693 628E 6047 4F8F CFA4  455E 1C62 A7DC 0255 ECA6
> > >
> > >
> >
> >
> > --
> > Jeroen Brattinga
> >
>
>
>
> --
> what we call human nature is actually human habit
> --
> http://gleamynode.net/
> --
> PGP key fingerprints:
> * E167 E6AF E73A CBCE EE41  4A29 544D DE48 FE95 4E7E
> * B693 628E 6047 4F8F CFA4  455E 1C62 A7DC 0255 ECA6
>
>


-- 
Jeroen Brattinga

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message