mina-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karsten Ohme <widerst...@t-online.de>
Subject Problems running server
Date Wed, 06 Jun 2007 11:55:53 GMT
Hi,

I want to use MINA for implementing a tunnel, but I have problems to run 
it. I experience the following:

I bind the SocketAcceptor
the run method of the Worker class is executed:

select returns because wakeup() is called by bind()
the request is registered with registerNew()
nKeys is 0
the keys are cancelled
during the second run:
select returns
keys are cancelled
selector keys are empty
registerQueue is empty
cancelQueue is empty

run exits

the program waits a while in some Executor... method and the server exits

I have tried this also with a simple ReverseSEchoerver example from your site (updated to
the 1.1 API). It shows teh same result. I want to connect with putty at 
port 
7070 but putty does simply exit.

I have attached the ReverseEchoServer sources (for Eclipse).

Regatrds,
Karsten




Mime
View raw message