mina-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Colin Koeck" <c...@arctosllc.com>
Subject RE: 40 ms intermittent latency - large volume, small messages
Date Mon, 02 Jul 2007 13:02:50 GMT
Yes, I tried disabling nagle's algorithm about a week ago, I haven't checked the log files
yet for latency but I will do so shortly.  Thanks to everyone for the tips!
 
Regards,
 
Colin

________________________________

From: peter royal [mailto:proyal@fnokd.com]
Sent: Sun 7/1/2007 6:39 PM
To: dev@mina.apache.org
Subject: Re: 40 ms intermittent latency - large volume, small messages



have you tried toggling tcp_nodelay?
-pete

-- 
peter royal - (on the go)


On Jul 1, 2007, at 2:25 PM, "Colin Koeck" <clk1@arctosllc.com> wrote:

> Hi, I've been experiencing intermittent latency with mina, generally 
> causing 37-40 millisecond delays.
>
> This occurs when I said large amounts of small messages (usually in 
> 5 - 20 count bursts, each message no more than 500 bytes) across a 
> 100Mbit ethernet network.  I'm using Linux running on dual-core 2.2 
> GHz AMD Opteron machines.
>
> I've found users having similiar problems with other software (39 ms 
> delays), in this case ActiveMQ
> http://www.nabble.com/High-latency-for-small-messages-problem-t3159901.html
> , which leads me to believe this is not directly related to mina.
>
> I have mina setup with SimpleByteBuffer allocating non-direct 
> memory.  I'm pretty sure this isn't a  direct problem with mina, but 
> I'm curious if anyone has experienced this problem with mina, and if 
> there is anyway to resolve this issue.  I would appreciate any help, 
> thanks!
>
> - Colin Koeck
> <mailto:clk1@arctosllc.com>



Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message