mina-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ashish <paliwalash...@gmail.com>
Subject Re: [3.0] IoSession attachment
Date Mon, 26 Oct 2009 15:55:09 GMT
On Mon, Oct 26, 2009 at 8:08 PM, Emmanuel Lecharny <elecharny@apache.org> wrote:
> Julien Vermillard wrote:
>>
>> That's the idea for me.
>>
>> kill IoSessionAttributMap,
>> put a Synchronized HashMap in AbstractIoSession
>> and provide only : getAttribute, setAttribute, removeAttribute,
>> getAttributeKeys (could be renamed to getAttributeNames)
>>
>
> I suggested we can have a contains( key ), but this is useless : a if (
> getAttribute( "blah" ) != null ) is doing exactly the same.
>

I think we should keep this API, its more intuitive to user (may be
coz we have similar API for most of Collections)

-- 
thanks
ashish

Mime
View raw message