mina-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emmanuel Lecharny (JIRA)" <j...@apache.org>
Subject [jira] Closed: (DIRMINA-618) Latest MINA won't work with glassfish as JCA inbound connector
Date Fri, 22 Jan 2010 17:35:21 GMT

     [ https://issues.apache.org/jira/browse/DIRMINA-618?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Emmanuel Lecharny closed DIRMINA-618.
-------------------------------------


> Latest MINA won't work with glassfish as JCA inbound connector
> --------------------------------------------------------------
>
>                 Key: DIRMINA-618
>                 URL: https://issues.apache.org/jira/browse/DIRMINA-618
>             Project: MINA
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 2.0.0-M3
>         Environment: Windows XP / Vista 
>            Reporter: Christopher Hurst
>            Priority: Blocker
>   Original Estimate: 168h
>  Remaining Estimate: 168h
>
> The latest version of Mina  (I believe 1.1.7 worked see link) has issues with Glassfish
when deployed as inbound JCA as reported else where (Has this been worked on ? / explained
?) ...
> http://www.nabble.com/MINA-and-Glassfish-td18767392.html
> The non working machine shows java.nio.channels.spi.SelectorProvider=com.sun.enterprise.ss.provider.ASSelector
 (from glassfish)
> the working machine shows this as unset, I've tried unsetting this myself  but it seems
not that simple, I guess its a case of when it has to be unset to take effect.
> On the failing machine attempting to connect via a NioSocketConnector establishes a connection
but it then goes horribly wrong usually with a null pointer exception in ...
> org.apache.mina.core.polling.AbstractPollingIoConnector
> ConnectionRequest connectionRequest(H handle);  returns null which causes the problem,
looks like lower down that the wrong set of keys is being obtained , decorated vs undecorated
ie right set of keys but they're wrapped by a decorator the key comparison can't cope with
..
> I noticed whilst debugging that interacting with the debugger (breakpoints) caused the
socket to work on my quad core vista box, then by recoding MINA to ignore the null pointers
it all sprang into life and appears stable once connected, however my dual core XP box still
doesn't work, obviously the vista box is way higher spec which may or may not effect the issue.
> I'm trying to bottom this out myself but any feedback would be useful, particularly if
some one has identified the issue already.
> I have a none JCA version of my code and it works fine everywhere as is.
> I notice using the debugger that the MINA code flow jumps into a glassfish lib appserv-rt
something to do with the selectors but haven't  got to the bottom of this yet.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message