mina-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Niklas Gustavsson <nik...@protocol7.com>
Subject Re: [FtpServer] Surefire plugin and JUnit versions and default logging level
Date Wed, 01 Jun 2011 07:09:45 GMT
On Tue, May 31, 2011 at 11:59 PM, sebb <sebbaz@gmail.com> wrote:
> The surefire plugin version in the FtpServer pom is currently 2.4.3,
> which is very old - the current version is 2.8.1.
> 2.4.3 does not even support systemPropertyVariables (2.5+).
>
> Likewise, JUnit is pegged at 3.8.2; the current version for Java 1.5+ is 4.8.2.
>
> Any objection to updating these?

None, go ahead.

> Also, the default logging level is DEBUG, which makes "mvn test" very noisy.
> I think WARN would be more appropriate for normal testing.
>
> Unfortunately it does not appear to be possible to override the
> logging level via a system parameter; the only way to do this is by
> modifying the log4j.properties file, or providing an alternative file.
>
> Would it be OK to change the default level in the log4j.properties file?

Yes.

/niklas

Mime
View raw message