mina-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Guillaume Nodet (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (SSHD-159) client should accept version "SSH-1.99"
Date Sat, 19 May 2012 18:42:40 GMT

     [ https://issues.apache.org/jira/browse/SSHD-159?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Guillaume Nodet resolved SSHD-159.
----------------------------------

    Resolution: Duplicate
    
> client should accept version "SSH-1.99"
> ---------------------------------------
>
>                 Key: SSHD-159
>                 URL: https://issues.apache.org/jira/browse/SSHD-159
>             Project: MINA SSHD
>          Issue Type: Bug
>    Affects Versions: 0.6.0
>            Reporter: Lee Breisacher
>
> I'm using SshClient to make a simple connection to a linux box. I'm getting the 
> following exception:
> org.apache.sshd.common.SshException: Unsupported protocol version: 
> SSH-1.99-OpenSSH_2.9p2
>         at 
> org.apache.sshd.client.session.ClientSessionImpl.readIdentification(ClientSessionImpl.java:388)
>         at 
> org.apache.sshd.common.session.AbstractSession.messageReceived(AbstractSession.java:226)
> I see this code in ClientSessionImpl>readIdentification():
>         if (!serverVersion.startsWith("SSH-2.0-")) {
>             throw new 
> SshException(SshConstants.SSH2_DISCONNECT_PROTOCOL_VERSION_NOT_SUPPORTED,
>                                    "Unsupported protocol version: " + 
> serverVersion);
>         }
> That serverVersion.startsWith needs to be a bit more forgiving, especially it needs to
accept SSH-1.99. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message