mina-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emmanuel Lecharny (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (DIRMINA-817) Packaging is buggy
Date Tue, 10 Jul 2012 14:34:34 GMT

     [ https://issues.apache.org/jira/browse/DIRMINA-817?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Emmanuel Lecharny resolved DIRMINA-817.
---------------------------------------

    Resolution: Cannot Reproduce

Seems like this is not possible to get the same error with Vysper, when building it with MINA
2.0.4
                
> Packaging is buggy
> ------------------
>
>                 Key: DIRMINA-817
>                 URL: https://issues.apache.org/jira/browse/DIRMINA-817
>             Project: MINA
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 2.0.2
>            Reporter: Haug B├╝rger
>              Labels: build
>             Fix For: 2.0.5
>
>
> Maven reported an error downloading. I found the following thread for it but no solution:
> http://www.mail-archive.com/dev@mina.apache.org/msg18170.html
> http://maven.apache.org/pom.html
> "When no packaging is declared, Maven assumes the artifact is the default: jar. The valid
types are Plexus role-hints (read more on Plexus for a explanation of roles and role-hints)
of the component role org.apache.maven.lifecycle.mapping.LifecycleMapping. The current core
packaging values are: pom, jar, maven-plugin, ejb, war, ear, rar, par. These define the default
list of goals which execute to each corresponding build lifecycle stage for a particular package
structure."
> the current pom contains:
> <packaging>bundle</packaging>
> This is not listed in the documentation above. Until you really know hat you are doing
you should change that to a supported value jar.
> I fixed it by adding the following to my pom, but...
>     <build>
>         <plugins>
>             <plugin>
>                 <groupId>org.apache.felix</groupId>
>                 <artifactId>maven-bundle-plugin</artifactId>
>                 <extensions>true</extensions>
>             </plugin>

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message