mina-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Lécharny <elecha...@gmail.com>
Subject Re: what is open ssl version in latest mina apache ftp server
Date Wed, 21 Nov 2012 10:59:55 GMT
Le 11/21/12 11:14 AM, securenamefirst securenamelast a écrit :
> Thanks Emmanuel,
> ok. that complicates the problem.
> i have application using jdk 1.5. i need to integrate ftp server to be able
> to do file transfer over TLS 1.1 which is only supported by JDK 1.7 or open
> ssl 1.0.1
>
> is it possible / how to have ftp server use jvm 1.7 , whilst being called
> from an application running against jdk 1.5 via the embedded method?
> or should i be looking at the standalone ftp server method running on
> a separate jdk installation, on same machine as jdk1.5 app and call it to
> do the transfer of files?

I'm afraid you have to start two JVMs (one using Java 5 and the other
one using Java 7), and exchange the data you want to expose via FTP
between those two JVMs.

Whay can't you just switch your JDK version on your application ? It
should work pretty straightforward on Java 1.7...

Keep in mind that Java 5 is EOL since October 2009, more than 4 years ago...

-- 
Regards,
Cordialement,
Emmanuel Lécharny
www.iktek.com 


Mime
View raw message