mina-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Ostrovsky (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SSHD-706) Error: GC overhead limit exceeded after upgrade to 1.3.0
Date Sun, 30 Oct 2016 20:09:58 GMT

    [ https://issues.apache.org/jira/browse/SSHD-706?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15620500#comment-15620500

David Ostrovsky commented on SSHD-706:

Thanks for merging. Unfortunately as you noticed, it hasn't fixed it. I investigated the thread
dumps and saw, that a lot of them was showing this location: in log message construction,
triggered from {{AbstractSession#checkForTimeouts}} method. That why I uploaded this PR.

With this patch applied and investigating thread dumps, I noticed, that a lot of them was
showing this location:  {{PropertyResolverUtils.getLongProperty}} methods, invoked form {{AbstractSession#checkForTimeouts}},
to retrieve the configured for {{FactoryManager.AUTH_TIMEOUT}} and {{FactoryManager.IDLE_TIMEOUT}}.
So i went ahead and change the code to cache timeout value configuration, as t was done for
other configuration values in {{AbstractSession}}: [1].

Unfortunately it hasn't solved the problem as well, I show still some location in thread dumps
in {{AbstractSession#checkForTimeouts}}. so just to make sure, i changed the scheduling in
our client code: [2] that the problem wasn't caused by this. Unfortunately, it also hasn't
fixed it. Now i don't see in stack dumps apache.sshd packages any more, so that i really clueless
how to troubleshoot the problem any further.

I tried to revert 549ac4e2a197afebbd9d66ccc1cd8506c0a515fb on master, but this produced non-trivial
to resolve conflicts ;-( Any idea how to proceed from here? 

[1] http://paste.openstack.org/show/587413
[2] http://paste.openstack.org/show/587414

> Error: GC overhead limit exceeded after upgrade to 1.3.0
> --------------------------------------------------------
>                 Key: SSHD-706
>                 URL: https://issues.apache.org/jira/browse/SSHD-706
>             Project: MINA SSHD
>          Issue Type: Bug
>    Affects Versions: 1.3.0
>         Environment: Gerrit Code Review
> Linux, 8 core, 32 GB RAM.
>            Reporter: David Ostrovsky
>         Attachments: stack_dumps_sshd_706.zip
> Since upgrade to SSHD 1.3.0 and Mina 2.0.15 junit tests are failing with:
> {code}
> java.lang.OutOfMemoryError: GC overhead limit exceeded
> {code}
> All is fine on SSHD 1.2.0 and Mina 2.0.10. 
> CL is here: 1 and CI log is here: 2.
> * 1. https://gerrit-review.googlesource.com/87435
> * 2. https://gerrit-ci.gerritforge.com/job/Gerrit-verifier-default/14968/consoleText

This message was sent by Atlassian JIRA

View raw message