mina-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Goldstein Lyor (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SSHD-874) Error decoding packet - WinSCP Issue - Need to know the SFTP Protocol version support for SSHD-CORE and SSHD-SFTP
Date Fri, 07 Dec 2018 18:03:00 GMT

    [ https://issues.apache.org/jira/browse/SSHD-874?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16713139#comment-16713139
] 

Goldstein Lyor commented on SSHD-874:
-------------------------------------

Nothing special - just set up the SSH server (as shown in the [project's README file|https://github.com/apache/mina-sshd/blob/master/README.md]),
start it and connect to it with {{WinSCP}} (or any SFTP client). If you wish to run a simple
test case just start up your favorite IDE (I use Eclipse) and run {{SshServerMainDevelopment}}
_main_ - please note that if you do not provide a {{-p NNNN}} port option it will use 8000
as the listen port.

> Error decoding packet - WinSCP Issue - Need to know the SFTP Protocol version support
for SSHD-CORE and SSHD-SFTP
> -----------------------------------------------------------------------------------------------------------------
>
>                 Key: SSHD-874
>                 URL: https://issues.apache.org/jira/browse/SSHD-874
>             Project: MINA SSHD
>          Issue Type: Bug
>            Reporter: Saravanakumar Vijayakumar
>            Assignee: Goldstein Lyor
>            Priority: Major
>
> Actually, The SFTP Server is properly working in Filezilla in ubuntu. But It is not working
in WinSCP. While listing the directory, It throws the following error.
> "Error decoding packet"
> I guess this problem due to the protocol version 6 is currently used by winscp. It works
when degrading the protocol version to 3. 
> Please advise me If I use the latest version of SSHD-CORE and SSHD-SFTP, this problem
can be resolved or not. 
> Please comment the SFTP protocol version support for the latest libraries. 



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message