mina-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lyor Goldstein <lgoldst...@apache.org>
Subject Re: SSHD 2.4.0
Date Fri, 17 Jan 2020 15:44:18 GMT
>>  Some of the tests do consistently fail on my laptop during the release
process....

Strange but not surprising - the MINA and NETTY tests do have inconsistent
intermittent failures . Usually if I run `mvn -rf :sshd-mina` (or whatever
failed) a few times they succeed. Note that it can happen also for
sshd-scp, sshd-sftp and others when run with the MINA or NETTY
implementations instead of NIO.

BTW, most of the time I compile the code on Windows - the few times I tried
it on Linux it succeeded - though I did encounter strange intermittent
failures from time to time.

Personally, I do not think it is an issue as long as the default (NIO)
succeeds and I do not deem this important enough to delay the release.
Therefore I recommend the following:

* Try `mvn -rf :sshd-mina` (or whatever failed) 2-3 times
* If other modules fail, make sure NIO succeeds - simply add
`-Dtest.mina=disable` (or -Dtest.netty=disable) to skip the relevant I/O
factory implementation.
*  If NIO succeeds but the rest fail consistently, add the failing tests to
the already existing exclusion list(s) in the relevant POM(s) under the
maven-surefire-plugin.

It is not optimal, but assuming we are talking about a minority of the
tests failing I believe it is acceptable - as long as the "main" NIO
(default) implementation passes.

  Note that there is a pending TODO to figure out why these tests fail
intermittently but we never seem to have enough time or manpower to do
that...

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message