mina-ftpserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Niklas Gustavsson" <nik...@protocol7.com>
Subject Re: SSL logout problem ?
Date Wed, 25 Jun 2008 12:12:18 GMT
On Mon, Jun 23, 2008 at 10:09 PM, Jeroen Cranendonk
<j.p.cranendonk@tursiops.org> wrote:
> Underneath is a log showing the error/warning that I get on disconnect
> (using the disconnect button on filezilla, which I think is a pretty well
> accepted way on closing the connection).
> When using flashfxp I seem the same thing happening, even when it first
> sends a QUIT (added a log for that after the filezilla one, hope the long
> mail isn't a problem! :) ).

Yes, this warning is a pain even though it can be ignored. Let me
investigate if we can mute that specific warning.

> Now this warning isn't such a big issue, but it seems the 'logout' code
> isn't called when this happens.
>
> The result of this is that I run out of logins, for example with 3
> 'anonymous logins' (which = 3 simultaneous logins),
> I will not be able to log in anymore after three -sequential- logins. And
> it's not hanging connections, even if I close the client entirely, and try
> to reconnect, I still get 'Response:    421 Maximum login limit has been
> reached.'
> I've even checked with the tcp view tool from sysinternals that there's
> really no connections left.
>
> So I think that because of the thrown exception, the code that normally
> decreases the login count isn't called, my guess anyways.
>
> Can someone please verify if this is a bug (and possibly fix it? or tell me
> how to fix it ;) ).

I've replicated the problem and opened a JIRA issue over here:
https://issues.apache.org/jira/browse/FTPSERVER-137

I'll look into the trouble further when I got some more time.

/niklas

Mime
View raw message