mrunit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brock Noland <br...@cloudera.com>
Subject MRUNIT-56 - 0.8.0 release does not work with Hadoop 0.23
Date Tue, 07 Feb 2012 04:48:28 GMT
Hi,

I am interested in your thoughts on:
https://issues.apache.org/jira/browse/MRUNIT-56  Basically, while the
source code we distribute works with 1.0 and 0.22/0.23, different bits
need to be built for the two versions. This is due to some class ->
interface changes. Users can do this themselves with the source but
since we distribute a jar, it would be handy to provide versions for
both 1.0 and 0.22/0.23.

I figured out a way to do this, but I am guessing it's largely suboptimal.

Cheers!
Brock

-- 
Apache MRUnit - Unit testing MapReduce - http://incubator.apache.org/mrunit/

Mime
View raw message