mrunit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jim Donofrio (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MRUNIT-98) DistributedCache support
Date Sun, 10 Jun 2012 01:08:42 GMT

    [ https://issues.apache.org/jira/browse/MRUNIT-98?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13292454#comment-13292454
] 

Jim Donofrio commented on MRUNIT-98:
------------------------------------

I agree there is too much duplicated code, some of it is difficult to abstract due to similar
map driver code but different api's, mapred vs mapreduce. Other parts of the code are difficult
to abstract because of the fluent with methods that have to have a return type of the actual
class, there is probably some good way to do that with generics
                
> DistributedCache support
> ------------------------
>
>                 Key: MRUNIT-98
>                 URL: https://issues.apache.org/jira/browse/MRUNIT-98
>             Project: MRUnit
>          Issue Type: New Feature
>    Affects Versions: 1.0.0
>            Reporter: Ajay Srivastava
>            Assignee: Dave Beech
>             Fix For: 1.0.0
>
>
> Created as MRUNIT-97 became a patch for InputSplits.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message