mrunit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dave Beech (JIRA)" <>
Subject [jira] [Commented] (MRUNIT-98) DistributedCache support
Date Sat, 09 Jun 2012 15:00:44 GMT


Dave Beech commented on MRUNIT-98:

This will probably need its own JIRA but I'll post here as I was working on this when I noticed

I'm a little concerned about the amount of duplicated code between the various driver classes,
specifically the run methods in MapDriver and ReduceDriver, the runTest methods in MapDriverBase
and ReduceDriverBase and the various set/add/with methods. 

It feels like a lot more stuff should be pulled up into a superclass. Any thoughts?
> DistributedCache support
> ------------------------
>                 Key: MRUNIT-98
>                 URL:
>             Project: MRUnit
>          Issue Type: New Feature
>    Affects Versions: 1.0.0
>            Reporter: Ajay Srivastava
>            Assignee: Dave Beech
>             Fix For: 1.0.0
> Created as MRUNIT-97 became a patch for InputSplits.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


View raw message