myfaces-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From lof...@apache.org
Subject svn commit: r1461715 - in /myfaces/tobago/trunk: src/site/fml/faq.fml tobago-example/pom.xml tobago-example/tobago-example-demo/pom.xml tobago-example/tobago-example-demo/src/main/webapp/WEB-INF/web.xml
Date Wed, 27 Mar 2013 17:13:10 GMT
Author: lofwyr
Date: Wed Mar 27 17:13:09 2013
New Revision: 1461715

URL: http://svn.apache.org/r1461715
Log:
Now it's possible to run the demo in WebSphere Liberty Profile

Modified:
    myfaces/tobago/trunk/src/site/fml/faq.fml
    myfaces/tobago/trunk/tobago-example/pom.xml
    myfaces/tobago/trunk/tobago-example/tobago-example-demo/pom.xml
    myfaces/tobago/trunk/tobago-example/tobago-example-demo/src/main/webapp/WEB-INF/web.xml

Modified: myfaces/tobago/trunk/src/site/fml/faq.fml
URL: http://svn.apache.org/viewvc/myfaces/tobago/trunk/src/site/fml/faq.fml?rev=1461715&r1=1461714&r2=1461715&view=diff
==============================================================================
--- myfaces/tobago/trunk/src/site/fml/faq.fml (original)
+++ myfaces/tobago/trunk/src/site/fml/faq.fml Wed Mar 27 17:13:09 2013
@@ -319,5 +319,93 @@ mvn selenium:start-server</source>
         </p>
       </answer>
     </faq>
+    <faq id="liberty">
+      <question>How can I run the Tobago demo with WebSphere Liberty Profile (WLP)
from Maven?</question>
+      <answer>
+        <p>
+          <b>Please use at least Tobago 1.6 for this guidance (in this version the
pom.xml files are prepared).</b>
+        </p>
+        <p>
+          You will need to do the following steps for preparation:
+        </p>
+        <ul>
+          <li>Download the server like:
+            <source>wlp-developers-8.5.next.beta.jar</source>
+            from
+            <a href="https://www.ibm.com/developerworks/mydeveloperworks/blogs/wasdev/entry/download?lang=en">IBM</a>
+            (Todo: check if this is the correct version)
+          </li>
+          <li>
+            Unpack the server anywhere in you file system, e.g. like this
+            <source>mkdir /opt/wlp-developers-8.5.next.beta
+cd /opt/wlp-developers-8.5.next.beta
+java -jar ~/Downloads/wlp-developers-8.5.next.beta.jar
+            </source>
+          </li>
+          <li>
+            Adding some features to the wlp/templates/servers/defaultServer/server.xml
+            <source>&lt;feature&gt;cdi-1.0&lt;/feature&gt;
+&lt;feature&gt;servlet-3.0&lt;/feature&gt;
+&lt;feature&gt;jsf-2.0&lt;/feature&gt;</source>
+          </li>
+          <li>
+            Adding your server home to a property in the settings.xml of Maven
+            <source>&lt;wlp.directory&gt;/opt/wlp-developers-8.5.next.beta&lt;/wlp.directory&gt;</source>
+          </li>
+        </ul>
+        <p>
+          After these steps you can start/stop the server and deploy an built artifact.
+          For these steps, you need to be in a Tobago example directory.
+          <source>cd tobago-examples/tobago-example-demo</source>
+        </p>
+        <ul>
+          <li>
+            Start the server
+            <source>mvn liberty:start-server</source>
+          </li>
+          <li>
+            Build an artifact (you need the "provided" property, because JSF and OWB comes
from the server)
+            <source>mvn package -Djsf=provided</source>
+          </li>
+          <li>
+            Deploy an artifact
+            <source>mvn liberty:deploy</source>
+          </li>
+          <li>
+            You will find the web application under this URL
+            <source>http://localhost:9080/tobago-example-demo/</source>
+          </li>
+          <li>
+            Redeploy an artifact: The same as deploy.
+          </li>
+          <li>
+            Stop the server
+            <source>mvn liberty:stop-server</source>
+          </li>
+        </ul>
+        <p>
+          The server starts very fast and is simple to use (very different from the full
WebSphere installation).
+          The log files you will find here:
+          <source>cd /opt/wlp-developers-8.5.next.beta/wlp/usr/servers/tobago/logs/</source>
+          Sometime you may need to the clean the server, in particular when you are changing
JAR dependencies.
+          For doing that
+        </p>
+        <ul>
+          <li>
+            Stop the server
+          </li>
+          <li>
+            Remove the whole concrete server installation
+            <source>rm -r /opt/wlp-developers-8.5.next.beta/wlp/usr/servers/tobago</source>
+          </li>
+          <li>
+            Start the server
+          </li>
+          <li>
+            Deploy again
+          </li>
+        </ul>
+      </answer>
+    </faq>
   </part>
 </faqs>

Modified: myfaces/tobago/trunk/tobago-example/pom.xml
URL: http://svn.apache.org/viewvc/myfaces/tobago/trunk/tobago-example/pom.xml?rev=1461715&r1=1461714&r2=1461715&view=diff
==============================================================================
--- myfaces/tobago/trunk/tobago-example/pom.xml (original)
+++ myfaces/tobago/trunk/tobago-example/pom.xml Wed Mar 27 17:13:09 2013
@@ -41,56 +41,13 @@
         <groupId>org.mortbay.jetty</groupId>
         <artifactId>jetty-maven-plugin</artifactId>
       </plugin>
-<!--
-      <plugin>
-      &lt;!&ndash; install the liberty server zip into the local maven repo &ndash;&gt;
-          <groupId>org.apache.maven.plugins</groupId>
-          <artifactId>maven-install-plugin</artifactId>
-          <version>2.2</version>
-          <executions>
-              <execution>
-                  <id>install-liberty-to-repo</id>
-                  <phase>process-resources</phase>
-                  <goals>
-                      <goal>install-file</goal>
-                  </goals>
-                  <configuration>
-                      <file>/Volumes/C/IBM/IMShared/native/wlp_1.0.1.cl0120121004-1949.zip</file>
-                      <groupId>com.ibm.ws.liberty.test</groupId>
-                      <artifactId>liberty-test-server</artifactId>
-                      <version>1.0</version>
-                      <packaging>zip</packaging>
-                  </configuration>
-               </execution>
-      </executions>
-      </plugin>
--->
-      <!-- install the liberty server as maven artifact -->
-<!--
+      <!-- The usage is documented in the FAQ -->
       <plugin>
         <groupId>com.ibm.websphere.wlp.maven.plugins</groupId>
         <artifactId>liberty-maven-plugin</artifactId>
         <version>1.0</version>
         <executions>
           <execution>
-            <id>install-liberty-server</id>
-            <phase>compile</phase>
-            <goals>
-              <goal>install-server</goal>
-            </goals>
-          </execution>
-          <execution>
-            <id>create-liberty-server</id>
-            <phase>pre-integration-test</phase>
-            <goals>
-              <goal>create-server</goal>
-            </goals>
-            <configuration>
-              <serverHome>${project.build.directory}/wlp</serverHome>
-              <serverName>test</serverName>
-            </configuration>
-          </execution>
-          <execution>
             <id>deployapp</id>
             <phase>pre-integration-test</phase>
             <goals>
@@ -99,17 +56,11 @@
           </execution>
         </executions>
         <configuration>
-          <assemblyArtifact>
-            <groupId>com.ibm.ws.liberty.test</groupId>
-            <artifactId>liberty-test-server</artifactId>
-            <version>1.0</version>
-            <type>zip</type>
-          </assemblyArtifact>
+          <serverHome>${wlp.directory}/wlp</serverHome>
           <appArchive>${project.build.directory}/${project.build.finalName}.war</appArchive>
-          <serverName>test</serverName>
+          <serverName>tobago</serverName>
         </configuration>
       </plugin>
--->
     </plugins>
   </build>
 
@@ -124,9 +75,8 @@
       <id>codehaus-snapshots</id>
       <url>http://snapshots.repository.codehaus.org/</url>
     </pluginRepository>
-<!--
     <pluginRepository>
-      &lt;!&ndash; For IBM Websphere &ndash;&gt;
+      <!-- For IBM Websphere Liberty Profile (WLP) -->
       <id>Liberty</id>
       <name>Liberty Repository</name>
       <url>http://public.dhe.ibm.com/ibmdl/export/pub/software/websphere/wasdev/maven/repository/</url>
@@ -138,7 +88,6 @@
         <enabled>true</enabled>
       </releases>
     </pluginRepository>
--->
   </pluginRepositories>
 
   <dependencies>
@@ -255,11 +204,13 @@
           <groupId>org.apache.myfaces.core</groupId>
           <artifactId>myfaces-api</artifactId>
           <version>${myfaces20.version}</version>
+          <scope>provided</scope>
         </dependency>
         <dependency>
           <groupId>org.apache.myfaces.core</groupId>
           <artifactId>myfaces-impl</artifactId>
           <version>${myfaces20.version}</version>
+          <scope>provided</scope>
         </dependency>
       </dependencies>
     </profile>

Modified: myfaces/tobago/trunk/tobago-example/tobago-example-demo/pom.xml
URL: http://svn.apache.org/viewvc/myfaces/tobago/trunk/tobago-example/tobago-example-demo/pom.xml?rev=1461715&r1=1461714&r2=1461715&view=diff
==============================================================================
--- myfaces/tobago/trunk/tobago-example/tobago-example-demo/pom.xml (original)
+++ myfaces/tobago/trunk/tobago-example/tobago-example-demo/pom.xml Wed Mar 27 17:13:09 2013
@@ -125,53 +125,32 @@
       <artifactId>geronimo-interceptor_1.1_spec</artifactId>
       <version>1.0</version>
     </dependency>
-    <dependency>
-      <groupId>org.apache.openwebbeans</groupId>
-      <artifactId>openwebbeans-impl</artifactId>
-      <version>${openwebbeans.version}</version>
-    </dependency>
-    <dependency>
-      <groupId>javassist</groupId>
-      <artifactId>javassist</artifactId>
-      <version>3.12.1.GA</version>
-    </dependency>
-    <dependency>
-      <groupId>org.apache.openwebbeans</groupId>
-      <artifactId>openwebbeans-spi</artifactId>
-      <version>${openwebbeans.version}</version>
-    </dependency>
-    <dependency>
-      <groupId>org.apache.openwebbeans</groupId>
-      <artifactId>openwebbeans-web</artifactId>
-      <version>${openwebbeans.version}</version>
-    </dependency>
-    <dependency>
-      <groupId>org.apache.openwebbeans</groupId>
-      <artifactId>openwebbeans-resource</artifactId>
-      <version>${openwebbeans.version}</version>
-    </dependency>
 
+    <!-- Codi -->
     <dependency>
       <groupId>org.apache.myfaces.extensions.cdi.core</groupId>
       <artifactId>myfaces-extcdi-core-api</artifactId>
       <version>${myfaces-extcdi.version}</version>
       <scope>compile</scope>
     </dependency>
-
     <dependency>
       <groupId>org.apache.myfaces.extensions.cdi.core</groupId>
       <artifactId>myfaces-extcdi-core-impl</artifactId>
       <version>${myfaces-extcdi.version}</version>
       <scope>runtime</scope>
     </dependency>
-
-<!-- which repository-->
     <dependency>
-      <groupId>org.apacheExtras.myfaces.codi.addon</groupId>
-      <artifactId>controlled-owb-bootstrapping-addon</artifactId>
-      <version>1.0.0</version>
+      <groupId>org.apache.myfaces.extensions.cdi.modules</groupId>
+      <artifactId>myfaces-extcdi-jsf20-module-api</artifactId>
+      <version>${myfaces-extcdi.version}</version>
       <scope>compile</scope>
     </dependency>
+    <dependency>
+      <groupId>org.apache.myfaces.extensions.cdi.modules</groupId>
+      <artifactId>myfaces-extcdi-jsf20-module-impl</artifactId>
+      <version>${myfaces-extcdi.version}</version>
+      <scope>runtime</scope>
+    </dependency>
 
     <dependency>
       <groupId>org.apache.myfaces.tobago</groupId>
@@ -251,23 +230,6 @@
       <classifier>tests</classifier>
       <scope>test</scope>
     </dependency>
-<!-- needed for Tomcat 5.5, TODO: make a JavaEE4 profile
-    <dependency>
-      <groupId>javax.el</groupId>
-      <artifactId>el-api</artifactId>
-      <version>1.0</version>
-      <scope>compile</scope>
-    </dependency>
--->
-    <!--dependency>
-      <groupId>com.sun.el</groupId>
-      <artifactId>el-ri</artifactId>
-      <version>1.0</version>
-      <scope>test</scope-->
-<!-- needed for Tomcat 5.5, TODO: make a JavaEE4 profile
-      <scope>compile</scope>
--->
-    <!--/dependency-->
 
     <dependency>
       <groupId>org.apache.geronimo.specs</groupId>
@@ -284,20 +246,20 @@
 
   </dependencies>
 
-  <!-- XXX repo für the controlled bootstrapping -->
-  <repositories>
-    <repository>
-      <id>googlecode.com</id>
-      <url>https://os890-m2-repository.googlecode.com/svn/tags/apache-extras</url>
-      <snapshots>
-        <enabled>false</enabled>
-      </snapshots>
-    </repository>
-  </repositories>
-
   <profiles>
 
     <profile>
+      <id>jsf-provided</id>
+      <!-- use this profile for containers that provide JSF and OWB e.g. WebSphere 8.5
-->
+      <activation>
+        <property>
+          <name>jsf</name>
+          <value>provided</value>
+        </property>
+      </activation>
+    </profile>
+
+    <profile>
       <id>myfaces-2.0</id>
       <activation>
         <property>
@@ -305,33 +267,39 @@
         </property>
       </activation>
       <dependencies>
+
+        <!-- OWB -->
         <dependency>
           <groupId>org.apache.openwebbeans</groupId>
           <artifactId>openwebbeans-jsf</artifactId>
           <version>${openwebbeans.version}</version>
         </dependency>
-
         <dependency>
-          <groupId>org.apache.myfaces.extensions.cdi.modules</groupId>
-          <artifactId>myfaces-extcdi-jsf20-module-api</artifactId>
-          <version>${myfaces-extcdi.version}</version>
-          <scope>compile</scope>
+          <groupId>org.apache.openwebbeans</groupId>
+          <artifactId>openwebbeans-web</artifactId>
+          <version>${openwebbeans.version}</version>
+        </dependency>
+        <dependency>
+          <groupId>org.apache.openwebbeans</groupId>
+          <artifactId>openwebbeans-resource</artifactId>
+          <version>${openwebbeans.version}</version>
         </dependency>
 
+        <!-- Codi for JavaEE5 -->
         <dependency>
-          <groupId>org.apache.myfaces.extensions.cdi.modules</groupId>
-          <artifactId>myfaces-extcdi-jsf20-module-impl</artifactId>
+          <groupId>org.apache.myfaces.extensions.cdi.modules.jee5-support</groupId>
+          <artifactId>myfaces-extcdi-jee5-openwebbeans-support</artifactId>
           <version>${myfaces-extcdi.version}</version>
           <scope>runtime</scope>
         </dependency>
-<!-- for JSF 2.0 and Bean Validation (JSR-303)  -->
+
+        <!-- for JSF 2.0 and Bean Validation (JSR-303)  -->
         <dependency>
           <groupId>javax.el</groupId>
           <artifactId>el-api</artifactId>
           <version>2.2</version>
           <scope>compile</scope>
         </dependency>
-
         <dependency>
           <groupId>org.glassfish.web</groupId>
           <artifactId>el-impl</artifactId>
@@ -350,26 +318,33 @@
         </property>
       </activation>
       <dependencies>
+
+        <!-- OWB -->
         <dependency>
           <groupId>org.apache.openwebbeans</groupId>
           <artifactId>openwebbeans-jsf</artifactId>
           <version>${openwebbeans.version}</version>
         </dependency>
-
         <dependency>
-          <groupId>org.apache.myfaces.extensions.cdi.modules</groupId>
-          <artifactId>myfaces-extcdi-jsf20-module-api</artifactId>
-          <version>${myfaces-extcdi.version}</version>
-          <scope>compile</scope>
+          <groupId>org.apache.openwebbeans</groupId>
+          <artifactId>openwebbeans-web</artifactId>
+          <version>${openwebbeans.version}</version>
+        </dependency>
+        <dependency>
+          <groupId>org.apache.openwebbeans</groupId>
+          <artifactId>openwebbeans-resource</artifactId>
+          <version>${openwebbeans.version}</version>
         </dependency>
 
+        <!-- Codi for JavaEE5 -->
         <dependency>
-          <groupId>org.apache.myfaces.extensions.cdi.modules</groupId>
-          <artifactId>myfaces-extcdi-jsf20-module-impl</artifactId>
+          <groupId>org.apache.myfaces.extensions.cdi.modules.jee5-support</groupId>
+          <artifactId>myfaces-extcdi-jee5-openwebbeans-support</artifactId>
           <version>${myfaces-extcdi.version}</version>
           <scope>runtime</scope>
         </dependency>
-<!-- for JSF 2.0 and Bean Validation (JSR-303)  -->
+
+        <!-- for JSF 2.0 and Bean Validation (JSR-303)  -->
         <dependency>
           <groupId>javax.el</groupId>
           <artifactId>el-api</artifactId>
@@ -395,26 +370,33 @@
         </property>
       </activation>
       <dependencies>
+
+        <!-- OWB -->
         <dependency>
           <groupId>org.apache.openwebbeans</groupId>
           <artifactId>openwebbeans-jsf</artifactId>
           <version>${openwebbeans.version}</version>
         </dependency>
-
         <dependency>
-          <groupId>org.apache.myfaces.extensions.cdi.modules</groupId>
-          <artifactId>myfaces-extcdi-jsf20-module-api</artifactId>
-          <version>${myfaces-extcdi.version}</version>
-          <scope>compile</scope>
+          <groupId>org.apache.openwebbeans</groupId>
+          <artifactId>openwebbeans-web</artifactId>
+          <version>${openwebbeans.version}</version>
+        </dependency>
+        <dependency>
+          <groupId>org.apache.openwebbeans</groupId>
+          <artifactId>openwebbeans-resource</artifactId>
+          <version>${openwebbeans.version}</version>
         </dependency>
 
+        <!-- Codi for JavaEE5 -->
         <dependency>
-          <groupId>org.apache.myfaces.extensions.cdi.modules</groupId>
-          <artifactId>myfaces-extcdi-jsf20-module-impl</artifactId>
+          <groupId>org.apache.myfaces.extensions.cdi.modules.jee5-support</groupId>
+          <artifactId>myfaces-extcdi-jee5-openwebbeans-support</artifactId>
           <version>${myfaces-extcdi.version}</version>
           <scope>runtime</scope>
         </dependency>
-<!-- for JSF 2.0 and Bean Validation (JSR-303)  -->
+
+        <!-- for JSF 2.0 and Bean Validation (JSR-303)  -->
         <dependency>
           <groupId>javax.el</groupId>
           <artifactId>el-api</artifactId>
@@ -440,26 +422,33 @@
         </property>
       </activation>
       <dependencies>
+
+        <!-- OWB -->
         <dependency>
           <groupId>org.apache.openwebbeans</groupId>
           <artifactId>openwebbeans-jsf</artifactId>
           <version>${openwebbeans.version}</version>
         </dependency>
-
         <dependency>
-          <groupId>org.apache.myfaces.extensions.cdi.modules</groupId>
-          <artifactId>myfaces-extcdi-jsf20-module-api</artifactId>
-          <version>${myfaces-extcdi.version}</version>
-          <scope>compile</scope>
+          <groupId>org.apache.openwebbeans</groupId>
+          <artifactId>openwebbeans-web</artifactId>
+          <version>${openwebbeans.version}</version>
+        </dependency>
+        <dependency>
+          <groupId>org.apache.openwebbeans</groupId>
+          <artifactId>openwebbeans-resource</artifactId>
+          <version>${openwebbeans.version}</version>
         </dependency>
 
+        <!-- Codi for JavaEE5 -->
         <dependency>
-          <groupId>org.apache.myfaces.extensions.cdi.modules</groupId>
-          <artifactId>myfaces-extcdi-jsf20-module-impl</artifactId>
+          <groupId>org.apache.myfaces.extensions.cdi.modules.jee5-support</groupId>
+          <artifactId>myfaces-extcdi-jee5-openwebbeans-support</artifactId>
           <version>${myfaces-extcdi.version}</version>
           <scope>runtime</scope>
         </dependency>
-<!-- for JSF 2.0 and Bean Validation (JSR-303)  -->
+
+        <!-- for JSF 2.0 and Bean Validation (JSR-303)  -->
         <dependency>
           <groupId>javax.el</groupId>
           <artifactId>el-api</artifactId>
@@ -492,26 +481,33 @@
         </repository>
       </repositories>
       <dependencies>
+
+        <!-- OWB -->
         <dependency>
           <groupId>org.apache.openwebbeans</groupId>
           <artifactId>openwebbeans-jsf</artifactId>
           <version>${openwebbeans.version}</version>
         </dependency>
-
         <dependency>
-          <groupId>org.apache.myfaces.extensions.cdi.modules</groupId>
-          <artifactId>myfaces-extcdi-jsf20-module-api</artifactId>
-          <version>${myfaces-extcdi.version}</version>
-          <scope>compile</scope>
+          <groupId>org.apache.openwebbeans</groupId>
+          <artifactId>openwebbeans-web</artifactId>
+          <version>${openwebbeans.version}</version>
+        </dependency>
+        <dependency>
+          <groupId>org.apache.openwebbeans</groupId>
+          <artifactId>openwebbeans-resource</artifactId>
+          <version>${openwebbeans.version}</version>
         </dependency>
 
+        <!-- Codi for JavaEE5 -->
         <dependency>
-          <groupId>org.apache.myfaces.extensions.cdi.modules</groupId>
-          <artifactId>myfaces-extcdi-jsf20-module-impl</artifactId>
+          <groupId>org.apache.myfaces.extensions.cdi.modules.jee5-support</groupId>
+          <artifactId>myfaces-extcdi-jee5-openwebbeans-support</artifactId>
           <version>${myfaces-extcdi.version}</version>
           <scope>runtime</scope>
         </dependency>
-<!-- for JSF 2.0 and Bean Validation (JSR-303)  -->
+
+        <!-- for JSF 2.0 and Bean Validation (JSR-303)  -->
         <dependency>
           <groupId>javax.el</groupId>
           <artifactId>el-api</artifactId>

Modified: myfaces/tobago/trunk/tobago-example/tobago-example-demo/src/main/webapp/WEB-INF/web.xml
URL: http://svn.apache.org/viewvc/myfaces/tobago/trunk/tobago-example/tobago-example-demo/src/main/webapp/WEB-INF/web.xml?rev=1461715&r1=1461714&r2=1461715&view=diff
==============================================================================
--- myfaces/tobago/trunk/tobago-example/tobago-example-demo/src/main/webapp/WEB-INF/web.xml
(original)
+++ myfaces/tobago/trunk/tobago-example/tobago-example-demo/src/main/webapp/WEB-INF/web.xml
Wed Mar 27 17:13:09 2013
@@ -95,30 +95,30 @@
   <listener>
     <listener-class>org.apache.myfaces.tobago.example.demo.info.ActivitySessionListener</listener-class>
   </listener>
-  <listener>
-    <listener-class>org.apache.myfaces.tobago.example.demo.info.ActivityServletContextListener</listener-class>
-  </listener>
 
   <!--  workaround (e.g. for Oracle AS 10.1.2.0.0)-->
+  <!--
   <listener>
     <listener-class>org.apache.myfaces.tobago.webapp.TobagoServletContextListener</listener-class>
   </listener>
-  <!-- activate this for jetty -->
+  -->
+
+  <!-- activate this for some containers -->
   <!--
   <listener>
     <listener-class>org.apache.myfaces.webapp.StartupServletContextListener</listener-class>
   </listener>
   -->
 
-<!--
+<!-- this is not needed for websphere 8.5 -->
   <listener>
     <listener-class>org.apache.webbeans.servlet.WebBeansConfigurationListener</listener-class>
   </listener>
--->
 
 <!-- this is an alternative to the WebBeansConfigurationListener
      you need it e.g. for Tomcat 5.5 or WebSphere 6.1 (see TOBAGO-1043)
 -->
+<!--
   <filter>
       <filter-name>webbeans</filter-name>
       <filter-class>org.apache.webbeans.servlet.WebBeansConfigurationFilter</filter-class>
@@ -134,12 +134,6 @@
   <listener>
     <listener-class>org.apache.webbeans.servlet.WebBeansConfigurationHttpSessionListener</listener-class>
   </listener>
-
-
-<!--
-  <listener>
-    <listener-class>org.apacheExtras.myfaces.codi.addon.openwebbeans.startup.OpenWebBeansAwareConfigurationListener</listener-class>
-  </listener>
 -->
 
   <!-- servlet -->



Mime
View raw message