nifi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean Busbey <bus...@cloudera.com>
Subject Re: Checkout develop source and nifi-kite-processors can��t find dependencies
Date Mon, 09 Mar 2015 16:09:08 GMT
the kite-parent that shows up in the maven central repository adds several
repositories[1] to check for its dependencies.

Can you verify that the one you get from mvnrepository.com also does?

Can you pastebin the output of your maven command so we can see if maven is
attempting to get to the add-on repositories?

What version of maven are you using?

Have you set up a local repository mirror setting that is meant to act as a
substitute for all repositories[2]?


[1]:
https://repo1.maven.org/maven2/org/kitesdk/kite-parent/0.18.0/kite-parent-0.18.0.pom
[2]:
http://maven.apache.org/guides/mini/guide-mirror-settings.html#Using_A_Single_Repository

On Mon, Mar 9, 2015 at 10:53 AM, Joe Witt <joe.witt@gmail.com> wrote:

> Toivo
>
> Ah ok - sorry didn't pay attention to the tests.  I was able to find
> all of those items without any problem.  Perhaps try building with all
> the debug voodoo that maven can offer so we can see more about the
> repositories being used?
>
> But it does appear related to the artifactory config.
>
> Thanks
> joe
>
> On Mon, Mar 9, 2015 at 11:38 AM, Toivo Adams <toivo.adams@gmail.com>
> wrote:
> > I am not sure I understand, but
> >
> > /nifi-kite-processors/pom.xml  contain
> >   <properties>
> >     <kite.version>0.18.0</kite.version>
> >     <guava.version>11.0.2</guava.version>
> >     <junit.version>4.10</junit.version>
> >     <findbugs-annotations.version>1.3.9-1</findbugs-annotations.version>
> >   </properties>
> >
> > . . .
> >
> >     <dependency>
> >       <groupId>org.kitesdk</groupId>
> >       <artifactId>kite-minicluster</artifactId>
> >       <version>${kite.version}</version>
> >       <scope>test</scope>
> >     </dependency>
> >
> > This leads to
> >
> > <project xmlns="http://maven.apache.org/POM/4.0.0"
> > xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> > xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
> > http://maven.apache.org/xsd/maven-4.0.0.xsd">
> >   <modelVersion>4.0.0</modelVersion>
> >   <artifactId>kite-minicluster</artifactId>
> >   <name>Kite Minicluster</name>
> >   <description />
> >
> >   <parent>
> >     <groupId>org.kitesdk</groupId>
> >     <artifactId>kite-parent</artifactId>
> >     <version>0.18.0</version>
> >     <relativePath>../pom.xml</relativePath>
> >   </parent>
> >
> >   <properties>
> >
> >     <vers.hive-cdh5>0.12.0-cdh${cdh5.version}</vers.hive-cdh5>
> >     <vers.flume-cdh5>1.4.0-cdh${cdh5.version}</vers.flume-cdh5>
> >   </properties>
> >
> > In Maven repo
> > http://mvnrepository.com/artifact/org.kitesdk/kite-minicluster/0.18.0
> > <dependency>
> >         <groupId>org.kitesdk</groupId>
> >         <artifactId>kite-minicluster</artifactId>
> >         <version>0.18.0</version>
> > </dependency>
> >
> > Depends on
> >                 org.apache.flume» flume-ng-node    1.4.0-cdh5.0.0
> >                 org.apache.hive» hive-common        0.12.0-cdh5.0.0
> >                 org.apache.hive» hive-exec              0.12.0-cdh5.0.0
> >                 org.apache.hive» hive-metastore     0.12.0-cdh5.0.0
> >                 org.apache.hive» hive-serde           0.12.0-cdh5.0.0
> >                 org.apache.hive» hive-service        0.12.0-cdh5.0.0
> >                 org.kitesdk» kite-data-core            0.18.0
> > . . .
> >
> > I am confused
> >
> > Thanks
> > Toivo
> >
> >
> >
> >
> > --
> > View this message in context:
> http://apache-nifi-incubating-developer-list.39713.n7.nabble.com/Re-Checkout-develop-source-and-nifi-kite-processors-can-t-find-dependencies-tp900p908.html
> > Sent from the Apache NiFi (incubating) Developer List mailing list
> archive at Nabble.com.
>



-- 
Sean

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message