nifi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Payne <marka...@hotmail.com>
Subject RE: Executing a python script with Execute Stream Command
Date Thu, 04 Jun 2015 13:57:00 GMT
Stephen,

Your understanding of the properties seem correct. Can you provide the properties that you're
using to configure the processor?

Thanks
-mark

----------------------------------------
> Date: Thu, 4 Jun 2015 09:51:46 -0400
> Subject: Executing a python script with Execute Stream Command
> From: stephen.pietrasko@g2-inc.com
> To: dev@nifi.incubator.apache.org; rob.weiss@g2-inc.com
>
> All,
>
> I am trying to configure the Execute Stream Command processor to execute a
> python script and have the output send to a queue with PutJMS.
>
> I'm having a bit of difficulty though. I've been looking at this previous
> email chain which is similar to my issue.
> https://www.mail-archive.com/dev@nifi.incubator.apache.org/msg01578.html
>
> The script runs and sends the output to sys.stdout.write but when I try and
> have NiFi run the script I see no bytes in or out which means nothing is
> passed to the queue.
>
> Would this be an issue with the output being sent to stdout or a property
> issue with ExecuteStreamCommand.
>
> I have tried several configurations of the property fields. This is my
> general understanding of each field and what they should be:
>
> Command Argument: name of script and arguments
> Command Path: python
> Working Directory: Directory where script is located.
>
> Any help would be greatly appreciated.
>
> --
> V/R
>
> Stephen M. Pietrasko
> Security Engineer
 		 	   		  
Mime
View raw message