nifi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Percivall <joeperciv...@yahoo.com.INVALID>
Subject Re: Master Branch Tests Failing on Windows
Date Thu, 12 Nov 2015 04:08:05 GMT
I like the thought but I just tried replacing all the "/" with File.separator and it still
failed the same way. I also tried it also on testPutFileWithException but I still got the
same NPE as I was getting before on this line:

        fs.setPermission(p,permission); 



- - - - - - 
Joseph Percivall
linkedin.com/in/Percivall
e: joepercivall@yahoo.com





On Wednesday, November 11, 2015 10:59 PM, Oleg Zhurakousky <ozhurakousky@hortonworks.com>
wrote:
Joe

I am gonna go out on the limb here, but do you think it may have something to do with forward
slashes “target/test-classes”?
Perhaps we may need to start using File.separator?

Oleg

On Nov 11, 2015, at 8:41 PM, Joe Percivall <joepercivall@yahoo.com.INVALID<mailto:joepercivall@yahoo.com.INVALID>>
wrote:

Hey Dev,

Is anyone building the project using Windows (specifically 8)?

I wanted to verify a patch I'm doing for ExecuteStreamCommand works on Windows. So I did a
fresh clone of the git repo and ran "mvn clean install" but I get seemingly random errors.
One such error is on PutHDFSTest line 178 (added an extra line to break up the logic):

List<MockFlowFile> failedFlowFiles = runner.getFlowFilesForRelationship(new Relationship.Builder().name("failure").build());
boolean isEmpty = failedFlowFiles.isEmpty();
assertTrue(isEmpty);

I get an AssertionError:

testPutFile(org.apache.nifi.processors.hadoop.PutHDFSTest)  Time elapsed: 5.223 sec  <<<
FAILURE!
java.lang.AssertionError: null
at org.junit.Assert.fail(Assert.java:86)
at org.junit.Assert.assertTrue(Assert.java:41)
at org.junit.Assert.assertTrue(Assert.java:52)
at org.apache.nifi.processors.hadoop.PutHDFSTest.testPutFile(PutHDFSTest.java:179)

Except that I was stepping through and saw that isEmpty was not null going into the assertion.

I have the feeling something is funky with my local system but can anyone verify that a clean
clone of the repo is working on Windows?

Thanks,
Joe

- - - - - -
Joseph Percivall
linkedin.com/in/Percivall<http://linkedin.com/in/Percivall>

e: joepercivall@yahoo.com

Mime
View raw message