nifi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matthew Clarke <matt.clarke....@gmail.com>
Subject Re: NCM and node on the same machine?
Date Tue, 16 Feb 2016 13:41:41 GMT
Sai,
      Did populating those fields on all your Nodes and NCM with values
solve your problem?  My feeling is that this is your issue.

You can also change the following logback.xml line to DEBUG from INFO on
your NCM so you can see the URL the NCM is trying to use to talk to each of
the nodes:

*<logger name="org.apache.nifi.cluster" level="INFO"/>*

Changes to the logback.xml file do not require a restart to take affect.

I suspect you will see URL with localhost in those DEBUG log messages.

Thanks,
Matt

On Tue, Feb 16, 2016 at 3:12 AM, Sai Kasturi <sai.kasturi123@gmail.com>
wrote:

> Hi Matthew,
>
> Thanks for the reply. To answer your question, the field,
> nifi.cluster.node.address=
> was left empty on the node which was on the same VM as the NCM and on the
> other node which was on the other VM the same field was given the IP
> address
> of the VM.
>
> nifi.cluster.manager.address=
>
> This field was given the IP of the NCM on both node instances.
>
> Hope this will help.
>
> Thanks
>
>
>
>
> -----
> Sai K
> --
> View this message in context:
> http://apache-nifi-developer-list.39713.n7.nabble.com/NCM-and-node-on-the-same-machine-tp7353p7363.html
> Sent from the Apache NiFi Developer List mailing list archive at
> Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message