nifi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bryan Bende <bbe...@gmail.com>
Subject Re: transportProtocol in flow.xml.gz?
Date Thu, 12 Jan 2017 15:47:44 GMT
Hey Joe,

This is definitely a known issue and I'm fairly certain there is a JIRA for
it, but can't find it since JIRA is having issues.

As you mentioned, it should not adversely affect anything though.

-Bryan

On Thu, Jan 12, 2017 at 8:24 AM, Joe Gresock <jgresock@gmail.com> wrote:

> I'm not sure if there's already a ticket (JIRA issue search appears to be
> down), but I'm seeing this in my nifi-bootstrap.log upon startup:
>
> 2017-01-12 13:19:52,373 ERROR [NiFi logging handler] org.apache.nifi.StdErr
> [Error] :19215:30: cvc-complex-type.2.4.a: Invalid content was found
> starting with element 'transportProtocol'. One of '{inputPort, outputPort}'
> is expected.
>
> I don't think it adversely affects anything, but it would be nice to defeat
> any invalid error statements in the logs.
>
> I don't remember when the transportProtocol was added, but this particular
> flow.xml.gz has gone through several upgrades, from 0.7.1 -> 1.1.0 ->
> 1.1.1.
>
> Here's an example of one of the remote processor group XML snippets from my
> flow file:
> <remoteProcessGroup>
>               <id>f897a1d9-2f0b-3b63-bf94-6f21edc7fffd</id>
>               <name>https://blahblah.internal:8443/nifi</name>
>               <position x="-162.41202073495504" y="1194.9929811217062"/>
>               <comment/>
>               <url>https://blahblah.internal:8443/nifi</url>
>               <timeout>60 sec</timeout>
>               <yieldPeriod>10 sec</yieldPeriod>
>               <transmitting>true</transmitting>
>               <transportProtocol>RAW</transportProtocol>
>               <proxyHost/>
>               <proxyUser/>
>               <inputPort>
>                 <id>141c9815-057e-4a21-9e4a-dfa4028420d9</id>
>                 <name>Audit input</name>
>                 <position x="0.0" y="0.0"/>
>                 <comments/>
>                 <scheduledState>RUNNING</scheduledState>
>                 <maxConcurrentTasks>1</maxConcurrentTasks>
>                 <useCompression>false</useCompression>
>               </inputPort>
>             </remoteProcessGroup>
>
> Should the XML order be different?  We're currently running 1.1.1.
>
> Thanks,
> Joe
>
> --
> I know what it is to be in need, and I know what it is to have plenty.  I
> have learned the secret of being content in any and every situation,
> whether well fed or hungry, whether living in plenty or in want.  I can do
> all this through him who gives me strength.    *-Philippians 4:12-13*
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message