nifi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pierre Villard <pierre.villard...@gmail.com>
Subject Re: PutMongo 1.3.0 - Upsert issue
Date Tue, 09 Jan 2018 16:08:52 GMT
Hi,

Easiest solution is probably to build the Mongo NAR with 1.5.0 code, and
drop it into your NiFi 1.3. This way you'll have the two versions of the
processor available in NiFi and you can easily switch from one version of
the processor to another.

https://nifi.apache.org/docs/nifi-docs/html/user-guide.html#component-versioning

Thanks
Pierre

2018-01-09 16:00 GMT+01:00 fabe_bdx <fmousnier@gertrude.fr>:

> Hi All,
>
> We actually used nifi 1.3.0, with a PutMongo 1.3.0 processor, we have an
> issue with the upsert capabilities of this processor.
>
> During the Upsert if an attribute of the document is not present in the
> request from putmongo, the processor suppress it the mongo document
> collection.
>
> We don"t find any solution to this problem for 1.3.0 version, but that seem
> to be resolved in the 1.5.0.
>
> Is it possible to apply a patch to 1.3.0 version to solve this problem ?
>
> Many thanks for your help.
>
> Fabien.
>
>
>
> --
> Sent from: http://apache-nifi-developer-list.39713.n7.nabble.com/
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message