nifi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Otto Fowler <ottobackwa...@gmail.com>
Subject Re: Issue with json.decode in jython 2.7.1
Date Wed, 13 Mar 2019 14:59:12 GMT
Can you create a jira?


On March 13, 2019 at 09:47:26, Kevin Hill (kevin@hyas.com) wrote:

Hi, I was wondering if it would be possible to upgrade the jython bundled
with nifi 1.9.0, which currently stands at 2.7.1. It appears there is a
very obscure bug related to multi-threading and json.decode that was fixed
between 2.7.1 and 2.7.2

I am trying to set up and ExecuteScript processor that needs to parse some
json log lines on some very large files, and I would very much like to use
more than one thread.

You can read more about the bug here:
https://bugs.jython.org/issue2609

-Kevin

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message