nifi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bryan Bende <bbe...@gmail.com>
Subject Minimum Maven Version
Date Tue, 26 Jan 2021 14:20:10 GMT
Since the beginning of the project our README has said "Maven >= 3.1",
which is obviously very old now. I was recently running into a problem
building main with Maven 3.3.9, that looks related to some new Maven
plugins in main depending on Maven 3.5.x apis. Switching to Maven
3.5.x resolved the issue, and I also regularly build with 3.6.3
without any issues.

I'd like to suggest that we state that the minimum Maven version is >=
3.5 now. This really doesn't mean too much other than updating the
README and setting the expectation of what should work.

If you are interested in when different versions of Maven have been
released, this page provides a nice listing -
https://maven.apache.org/docs/history.html

Thanks,

Bryan

Mime
View raw message