nifi-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Hamm <ceham...@gmail.com>
Subject Re: NIFI connecting to Activemq
Date Thu, 14 Jan 2016 06:17:23 GMT
Thanks for the update. Do you have suggestion what I should set my
processor to?
On Jan 9, 2016 8:25 PM, "Joe Witt" <joe.witt@gmail.com> wrote:

> Chris,
>
> Thanks for sending the screenshot.  The NullPointerException is
> trivially reproduced using your settings.  I didn't even need a JMS
> server to cause it.
>
> Have created a JIRA for this:
> https://issues.apache.org/jira/browse/NIFI-1378
>
> Thanks!
> Joe
>
>
>
> On Sat, Jan 9, 2016 at 3:21 PM, Oleg Zhurakousky
> <ozhurakousky@hortonworks.com> wrote:
> > Well, you URL is malformed, since it should be of form
> protocol://host:port.
> > Just look at any AMQ sample out there on the web. The part that worries
> me
> > is the NPE and nothing in the logs. Did you try Joe's suggestion and
> enable
> > Debug level logging?
> >
> > Sent from my iPhone
> >
> > On Jan 9, 2016, at 14:06, Christopher Hamm <email@christopherhamm.com>
> > wrote:
> >
> > Those logs came from a completely new restart with cleared logs.
> >
> > If have an ActiveMQ topic setup. What should each field have in it if it
> is
> > running locally and using port 61613? I think maybe the NPE is related to
> > bad network connection with my activeMQ. Can't find examples out there.
> > <NiFi_Flow-GetJMSQueue.png>
> >
> > On Sat, Jan 9, 2016 at 9:13 AM, Oleg Zhurakousky
> > <ozhurakousky@hortonworks.com> wrote:
> >>
> >> Chris
> >>
> >> Are you sure you are providing the correct logs? I can’t see a single
> >> mention of JMS nor any stack traces which would definitely be there
> given
> >> what you see in UI.
> >> Also, the fact that you see NPE is definitely a bug that we have to fix
> >> (user’s should never see NPE), so that can be filed. What I am trying to
> >> figure out is the condition that triggers it. May be if you shut down
> NIFI,
> >> delete all the logs and restart so you can get a fresh data. . .
> >>
> >> Cheers
> >> Oleg
> >>
> >> On Jan 9, 2016, at 1:42 AM, Christopher Hamm <email@christopherhamm.com
> >
> >> wrote:
> >>
> >> Here are the logs
> >>
> >> On Wed, Jan 6, 2016 at 11:32 PM, Joe Witt <joe.witt@gmail.com> wrote:
> >>>
> >>> Chris,
> >>>
> >>> Ok.  Can you take a look in the <nifi>/logs/nifi-app.log and see if
> there
> >>> is a stack trace for the NullPointerException included?
> >>>
> >>> If not please add the following to your logback.xml and after 30
> seconds
> >>> or so it should start giving you the stack traces.  A stacktrace for
> the NPE
> >>> would be really useful in pinpointing the likely issue.  Also please
> share
> >>> the config details of GetJMSQueue processor that you can.
> >>>
> >>> <logger name="org.apache.nifi.processors.standard.GetJMSQueue"
> >>> level="DEBUG"/>
> >>>
> >>> Thanks
> >>> Joe
> >>>
> >>> On Wed, Jan 6, 2016 at 11:16 PM, Christopher Hamm
> >>> <email@christopherhamm.com> wrote:
> >>>>
> >>>> Couldnt copy the text but here it is.
> >>>> <nifi-jms.png>
> >>>>
> >>>>
> >>>>
> >>>> On Wed, Jan 6, 2016 at 5:28 PM, Joe Witt <joe.witt@gmail.com>
wrote:
> >>>>>
> >>>>> Christopher,
> >>>>>
> >>>>> Is there any error/feedback showing up in the UI or in the logs?
> >>>>>
> >>>>> Thanks
> >>>>> Joe
> >>>>>
> >>>>> On Wed, Jan 6, 2016 at 5:19 PM, Christopher Hamm
> >>>>> <email@christopherhamm.com> wrote:
> >>>>> > What am I doing wrong with hooking up my activemq jms get
> template? I
> >>>>> > put
> >>>>> > stuff into the activeMQ and NIFI wont get it. Using 0.4.1.
> >>>>> >
> >>>>> > --
> >>>>> > Sincerely,
> >>>>> > Chris Hamm
> >>>>> > (E) cehamm01@gmail.com
> >>>>> > (Twitter) http://twitter.com/webhamm
> >>>>> > (Linkedin) http://www.linkedin.com/in/chrishamm
> >>>>
> >>>>
> >>>>
> >>>>
> >>>> --
> >>>> Sincerely,
> >>>> Chris Hamm
> >>>> (E) cehamm01@gmail.com
> >>>> (Twitter) http://twitter.com/webhamm
> >>>> (Linkedin) http://www.linkedin.com/in/chrishamm
> >>>
> >>>
> >>
> >>
> >>
> >> --
> >> Sincerely,
> >> Chris Hamm
> >> (E) cehamm01@gmail.com
> >> (Twitter) http://twitter.com/webhamm
> >> (Linkedin) http://www.linkedin.com/in/chrishamm
> >> <Nifi-logs.zip>
> >>
> >>
> >
> >
> >
> > --
> > Sincerely,
> > Chris Hamm
> > (E) cehamm01@gmail.com
> > (Twitter) http://twitter.com/webhamm
> > (Linkedin) http://www.linkedin.com/in/chrishamm
>

Mime
View raw message