nifi-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oleg Zhurakousky <ozhurakou...@hortonworks.com>
Subject Re: Nifi 0.50 and GetKafka Issues
Date Sat, 20 Feb 2016 20:36:52 GMT
Josh

Any chance to attache the app-log or relevant stack trace?

Thanks
Oleg

On Feb 20, 2016, at 3:30 PM, West, Joshua <Josh_West@bose.com<mailto:Josh_West@bose.com>>
wrote:

Hi folks,

I've upgraded from Nifi 0.4.1 to 0.5.0 and I am no longer able to use the GetKafka processor.
 I'm seeing errors like so:

2016-02-20 20:10:14,953 WARN [ConsumerFetcherThread-NiFi-sldjflkdsjflksjf_**SCRUBBED**-1455999008728-5b8c7108-0-0]
kafka.consumer.ConsumerFetcherThread [ConsumerFetcherThread-NiFi-sldjflkdsjflksjf_**SCRUBBED**-1455999008728-5b8c7108-0-0],
Error in fetchkafka.consumer.ConsumerFetcherThread$FetchRequest@7b49a642<mailto:kafka.consumer.ConsumerFetcherThread$FetchRequest@7b49a642>.
Possible cause: java.lang.IllegalArgumentException

^ Note  the hostname of the server has been scrubbed.

My configuration is pretty generic, except that with Zookeeper we use a different root path,
so our Zookeeper connect string looks like so:

zookeeper-node1:2181,zookeeper-node2:2181,zookeeper-node3:2181/kafka

Is anybody else experiencing issues?

Thanks.


--
Josh West <josh_west@bose.com<mailto:josh_west@bose.com>>

Cloud Architect
Bose Corporation





Mime
View raw message