nifi-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Keith Lim <Keith....@ds-iq.com>
Subject Re: Failure when running a workflow created from a template from another NiFi version.
Date Fri, 10 Jun 2016 16:57:18 GMT
The jar files are dated/built on 2016/05/25, but I don't know from what exact source it was
built from.  Is there another place/file? I can check a property that would pinpoint the exact
source snapshot?


Thanks,
Keith

________________________________
From: James Wing <jvwing@gmail.com>
Sent: Thursday, June 09, 2016 10:47:23 PM
To: users@nifi.apache.org
Subject: Re: Failure when running a workflow created from a template from another NiFi version.

I agree with you Matt, it sounds very similar to the issue reported in NIFI-1752 "EvaluateXPath
invalid when starting processor" (https://issues.apache.org/jira/browse/NIFI-1752), but resolved
by the NarCloseable fix as part of NIFI-1697.  I believe it is possible that 0.7.0-SNAPSHOT
might have this problem if it was built after 0.6.0, but before the 0.6.1 fixes were merged.
 My hazy timeline looks like this:

March 26 - 0.6.0 released
March 30 - 0.7.0-SNAPSHOT version applied in e977729 (https://github.com/apache/nifi/commit/e977729b562c02f6eeb3c66e6e5187c631b9b168)
April 4 - NarClosable fix merged to master and support
April 11 - NIFI-1752 reporting EvaluateXPath invalid state issue in 0.6.0
April 18 - 0.6.1 released with NarClosable fix from NIFI-1697

I'm not sure I have that exactly right, but there seems to be a week or so when it would be
possible to build 0.7.0-SNAPSHOT such that the template migration is actually going back to
an earlier code base, with respect to this issue.  Though it does seem pretty unlikely now
that I've typed this far.

Keith, you wouldn't happen to know the date you built 0.7.0-SNAPSHOT, or be able to look at
the dates on some of the jar files?


Thanks,

James

On Thu, Jun 9, 2016 at 4:44 PM, Matt Burgess <mattyb149@gmail.com<mailto:mattyb149@gmail.com>>
wrote:
Not to stir the pot but the only time I've seen that error was a Jira that was fixed for 0.6.1,
in fact I think I recommended such an upgrade for someone with the same problem. I'm glad
the issue went away but it's weird that it showed up in 0.6.1...


On Jun 9, 2016, at 7:41 PM, James Wing <jvwing@gmail.com<mailto:jvwing@gmail.com>>
wrote:

Thanks for reporting back, Keith. It sounds like a bug got fixed, and that's always great
news even if we don't exactly where :).

James

On Thu, Jun 9, 2016 at 4:10 PM, Keith Lim <Keith.Lim@ds-iq.com<mailto:Keith.Lim@ds-iq.com>>
wrote:

Thanks James,  I built from the latest 0.x branch and the issue does not show up.


Thanks,
Keith


________________________________
From: James Wing <jvwing@gmail.com<mailto:jvwing@gmail.com>>
Sent: Wednesday, June 08, 2016 9:23:22 PM
To: users@nifi.apache.org<mailto:users@nifi.apache.org>
Subject: Re: Failure when running a workflow created from a template from another NiFi version.

Do you know how recently your 0.7.0-SNAPSHOT was built from source?  Have you tried the latest
code in the 0.x branch?

Thanks,

James

On Wed, Jun 8, 2016 at 5:43 PM, Keith Lim <Keith.Lim@ds-iq.com<mailto:Keith.Lim@ds-iq.com>>
wrote:

My repro was when I start the workflow, the error message shows up and was on nifi-0.7.0-SNAPSHOT
with java 1.8.0_91.


Thanks,
Keith

________________________________
From: James Wing <jvwing@gmail.com<mailto:jvwing@gmail.com>>
Sent: Wednesday, June 08, 2016 4:59 PM
To: users@nifi.apache.org<mailto:users@nifi.apache.org>
Subject: Re: Failure when running a workflow created from a template from another NiFi version.

I was able to import the template without errors on Windows 10, running the latest 0.x branch
(c4ddb52) and Java 1.8.0_66.  Can you expand on your NiFi version, Java etc?

Thanks,

James

On Wed, Jun 8, 2016 at 4:18 PM, Keith Lim <Keith.Lim@ds-iq.com<mailto:Keith.Lim@ds-iq.com>>
wrote:

Hi James,


Here is the template.  Need to remove the .txt extension.

Note: I didn't bother to put in the correct flowfile xpath content for the processor to evaluate
to success result.


Thanks,
Keith





________________________________
From: James Wing <jvwing@gmail.com<mailto:jvwing@gmail.com>>
Sent: Wednesday, June 08, 2016 3:59 PM
To: users@nifi.apache.org<mailto:users@nifi.apache.org>
Subject: Re: Failure when running a workflow created from a template from another NiFi version.

Keith,

Would you be able to share your sample template with us as an attachment, a GitHub Gist, or
something similar?

Thanks,

James

On Wed, Jun 8, 2016 at 3:36 PM, Keith Lim <Keith.Lim@ds-iq.com<mailto:Keith.Lim@ds-iq.com>>
wrote:
Hi Joe,

I created a simple workflow with EvaluateXPath and managed to repro the issue.
Here is the snapshot of the screen.  This is on Windows with 0.7.0 snapshot.    There is no
issue on 0.6.1 on Windows and 0.7.0 on Linux.

We can't roll back to 0.6.1 as we have a dependency on a feature in 0.7.0

Thanks,
Keith

<pastedImage.png>



________________________________________
From: Keith Lim <Keith.Lim@ds-iq.com<mailto:Keith.Lim@ds-iq.com>>
Sent: Wednesday, June 08, 2016 10:28 AM
To: users@nifi.apache.org<mailto:users@nifi.apache.org>
Subject: Re: Failure when running a workflow created from a template from another NiFi version.

Hi Joe,

Interesting... I didn't find anything in the nifi-app.log, however, I found these logged in
the nifi.user.log.

2016-06-08 10:18:22,089 INFO [NiFi Web Server-20] org.apache.nifi.web.filter.RequestLogger
Attempting request for (anonymous) PUT http://nifi.dev.azure.ds-iq.corp:10000/nifi-api/controller/process-groups/658947de-a030-3832-95a6-1f4d2b346131
(source ip: 10.200.0.31)
2016-06-08 10:18:22,089 INFO [NiFi Web Server-20] o.a.n.w.a.c.IllegalStateExceptionMapper
java.lang.IllegalStateException: EvaluateXPath[id=6c73cffa-0d34-3b25-94d4-14d115b8b62b] is
not in a valid state. Returning Conflict response.
2016-06-08 10:18:24,636 INFO [NiFi Web Server-18] org.apache.nifi.web.filter.RequestLogger
Attempting request for (anonymous) GET http://nifi.dev.azure.ds-iq.corp:10000/nifi-api/controller
(source ip: 10.200.0.31)
2016-06-08 10:18:25,324 INFO [NiFi Web Server-22] org.apache.nifi.web.filter.RequestLogger
Attempting request for (anonymous) GET http://nifi.dev.azure.ds-iq.corp:10000/nifi-api/controller
(source ip: 10.200.0.31)
2016-06-08 10:18:29,511 INFO [NiFi Web Server-24] org.apache.nifi.web.filter.RequestLogger
Attempting request for (anonymous) PUT http://nifi.dev.azure.ds-iq.corp:10000/nifi-api/controller/process-groups/658947de-a030-3832-95a6-1f4d2b346131
(source ip: 10.200.0.31)
2016-06-08 10:18:29,542 INFO [NiFi Web Server-24] o.a.n.w.a.c.IllegalStateExceptionMapper
java.lang.IllegalStateException: EvaluateXPath[id=6c73cffa-0d34-3b25-94d4-14d115b8b62b] is
not in a valid state. Returning Conflict response.


This is the message box I got when I tried to run my workflow:
Node azudevmgmt01.ds-iq.corp:10001 is unable to fulfill this request due to: EvaluateXPath[id=6c73cffa-0d34-3b25-94d4-14d115b8b62b]
is not in a valid state

Thanks,
Keith

________________________________________
From: Joe Witt <joe.witt@gmail.com<mailto:joe.witt@gmail.com>>
Sent: Wednesday, June 08, 2016 10:02 AM
To: users@nifi.apache.org<mailto:users@nifi.apache.org>
Subject: Re: Failure when running a workflow created from a template from another NiFi version.

Keith,

Can you collect more information on this from the nifi-app.log?  Not
in valid state should be associated with some exceptions and such that
ideally will be in the logs.

Thanks
Joe

On Wed, Jun 8, 2016 at 1:00 PM, Keith Lim <Keith.Lim@ds-iq.com<mailto:Keith.Lim@ds-iq.com>>
wrote:
> Any help on this before while I am upgrading my NiFi to 0.7.0
>
>
> If this is an incompatibility issue between source (where the workflow is
> developed) and target NiFi (where the workflow is imported into and run),
> how is it best to deal with it without having to rewrite in new version?
>
>
> Thanks,
> Keith
>
> ________________________________
>
> From: Keith Lim <Keith.Lim@ds-iq.com<mailto:Keith.Lim@ds-iq.com>>
> Sent: Tuesday, June 07, 2016 5:07 PM
> To: users@nifi.apache.org<mailto:users@nifi.apache.org>
> Subject: Failure when running a workflow created from a template from
> another NiFi version.
>
>
> I am getting a weird error when I ran a workflow created from a template
> exported from another NiFi environment.
>
>
> The source template was developed in NiFi 0.6.1 and I ran it on 0.7.0.
>
>
> The error is
>
> Node <mymachinenode> is unable to fulfill this request due to:
> EvaluateXPath[id=6c73cffa-0d34-3b25-94d4-14d115b8b62b] is not in a valid
> state
>
>
> I went on to delete the processor instance in question and reran, and it
> would complaint the next processor until none is left.  I was wondering this
> is related to upgrade and how is best to fix it without having to re-write
> the whole workflow on the new version?
>
> Thanks,
> Keith
>
>






Mime
View raw message