nifi-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Keith Lim <Keith....@ds-iq.com>
Subject Re: Failure when running a workflow created from a template from another NiFi version.
Date Wed, 08 Jun 2016 17:00:00 GMT
Any help on this before while I am upgrading my NiFi to 0.7.0


If this is an incompatibility issue between source (where the workflow is developed) and target
NiFi (where the workflow is imported into and run), how is it best to deal with it without
having to rewrite in new version?


Thanks,
Keith

________________________________

From: Keith Lim <Keith.Lim@ds-iq.com>
Sent: Tuesday, June 07, 2016 5:07 PM
To: users@nifi.apache.org
Subject: Failure when running a workflow created from a template from another NiFi version.


I am getting a weird error when I ran a workflow created from a template exported from another
NiFi environment.


The source template was developed in NiFi 0.6.1 and I ran it on 0.7.0.


The error is

Node <mymachinenode> is unable to fulfill this request due to: EvaluateXPath[id=6c73cffa-0d34-3b25-94d4-14d115b8b62b]
is not in a valid state

I went on to delete the processor instance in question and reran, and it would complaint the
next processor until none is left.  I was wondering this is related to upgrade and how is
best to fix it without having to re-write the whole workflow on the new version?

Thanks,
Keith



Mime
View raw message