nifi-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Witt <joe.w...@gmail.com>
Subject Re: GetDynamoDB Processor
Date Wed, 26 Oct 2016 11:20:44 GMT
Nice.  James - do you plan to file a JIRA for this or was there already one?

Thanks
Joe

On Wed, Oct 26, 2016 at 1:50 AM, Pablo Lopez
<pablo.lopez@integrado.com.au> wrote:
> It worked!
> I had to actually delete the Processor and add a new new. Stopping and
> starting the Processor or the Flow didn't actually work.
>
> Thanks,
> Pablo.
>
> On Wed, Oct 26, 2016 at 3:59 PM, James Wing <jvwing@gmail.com> wrote:
>>
>> Pablo,
>>
>> Did you by any chance start the GetDynamoDB processor first without the
>> credentials, then stop, configure credentials, and restart?  I suspect there
>> might be a bug where GetDynamoDB caches the client even through stopping and
>> starting the processor.
>>
>> To test this theory, you might try copy/pasting the GetDynamoDB processor
>> and configure the access keys on the new one before starting it.
>>
>> Thanks,
>>
>> James
>>
>> On Tue, Oct 25, 2016 at 4:35 PM, Pablo Lopez
>> <pablo.lopez@integrado.com.au> wrote:
>>>
>>> Hi,
>>>
>>> I've been trying to get GetDynamoDB processor to work. I've configured
>>> the AccessKey and SecretKey but i'm still getting Exception
>>> MissingAuthenticationTokenException. Any ideas?
>>>
>>> This is the Error from the Bulletin Board.
>>>
>>> GetDynamoDB[id=f14db94a-0157-1000-4a66-5f7d9437a744] Could not process
>>> flowFiles due to service exception : Request is missing Authentication Token
>>> (Service: AmazonDynamoDBv2; Status Code: 400; Error Code:
>>> MissingAuthenticationTokenException; Request ID:
>>> 3SB9O22VV16LE1BV31A79DD7QBVV4KQNSO5AEMVJF66Q9ASUAAJG)
>>>
>>> Thanks,
>>> Pablo.
>>
>>
>
>
>
> --
> Pablo Lopez.
> Integration Architect
> Integrado Pty Ltd
> M: 044 84 52 479
> pablo.lopez@integrado.com.au

Mime
View raw message