nifi-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Percivall <joeperciv...@yahoo.com>
Subject Re: MQTT Publisher errors
Date Thu, 03 Nov 2016 13:39:36 GMT
Hello,
Sorry you are having problems with PublishMQTT. What MQTT broker are you trying to hit? and
could you pass along what configuration you have set (including scheduling tab)? I'd like
to try and reproduce if possible.
I'm guessing there is nothing more to that stacktrace? I ask (hoping that there is) because
no where in the stacktrace does it indicate a line in the NiFi codebase which would mean it's
potentially a timing issue related to the concurrency of background threads. Making it harder
to track down and fix.
Any other insight into your configuration/set-up would be appreciated. Thanks,Joe- - - -
- - Joseph Percivalllinkedin.com/in/Percivalle: joepercivall@yahoo.com
 

    On Thursday, November 3, 2016 5:10 AM, michail salichos <michail.salichos@gmail.com>
wrote:
 

 Hello,
I am getting random errors using MQTT Publisher processor from v1.0.0.
Although the exceptions are raised, sometimes messages are published, sometimes not. I have
not managed to find a pattern nor the cause, it seems to be totally random.
I have tried publishing messages to the same broker, using the same MQTT client configuration
(e.g. QoS) and the same credentials using mosquitto_pub and JAVA paho custom client (same
version as the one used in NiFI 1.0.0), and everything works well. Only when I use NiFI MQTT
publisher I get these errors. 
Any tips or hints?

(*)-MQTT client is disconnected and re-connecting failed. Transferring FlowFile to fail and
yielding
or
-o.a.nifi.processors.mqtt.PublishMQTT PublishMQTT[id=f6ee1833-0157-1000-63a0-ad3c0072ca5f]
Was disconnected from client or was never connected, attempting to connect
or
-o.a.nifi.processors.mqtt.PublishMQTT PublishMQTT[id=f6f5b090-0157-1000-d924-211d02de8856]
Connection to tcp://api-test.iotcloud.swisscom.com:1883 lostorg.eclipse.paho.client.mqttv3.MqttException:
Connection lost        at org.eclipse.paho.client.mqttv3.internal.CommsReceiver.run(CommsReceiver.java:146)
[org.eclipse.paho.client.mqttv3-1.0.2.jar:na]        at java.lang.Thread.run(Thread.java:745)
[na:1.8.0_91]Caused by: java.io.EOFException: null        at java.io.DataInputStream.readByte(DataInputStream.java:267)
~[na:1.8.0_91]        at org.eclipse.paho.client.mqttv3.internal.wire.MqttInputStream.readMqttWireMessage(MqttInputStream.java:65)
~[org.eclipse.paho.client.mqttv3-1.0.2.jar:na]        at org.eclipse.paho.client.mqttv3.internal.CommsReceiver.run(CommsReceiver.java:107)
[org.eclipse.paho.client.mqttv3-1.0.2.jar:na]        ... 1 common frames omitted 


   
Mime
View raw message