nifi-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Manojkumar Ravichandran <sendmailt...@gmail.com>
Subject Re: UI is not opening after forming nifi 1.0.0 secure cluster in windows
Date Fri, 11 Nov 2016 06:54:04 GMT
Hi,

Thanks for your response,error I received in browser has been attached

I have generated the key store and truststore file using the java keytool,
Is it necessary to generate the key file in open ssl ?

In nifi-app.log everything seems right,except this warning message

org.apache.nifi.cluster.protocol.ProtocolException: Failed marshalling
protocol message in response to message type: CONNECTION_REQUEST due to
java.net.SocketException: Software caused connection abort: socket write
error
at
org.apache.nifi.cluster.protocol.impl.SocketProtocolListener.dispatchRequest(SocketProtocolListener.java:176)
~[nifi-framework-cluster-protocol-1.0.0.jar:1.0.0]
at
org.apache.nifi.io.socket.SocketListener$2$1.run(SocketListener.java:136)
[nifi-socket-utils-1.0.0.jar:1.0.0]
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
[na:1.8.0_91]
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
[na:1.8.0_91]
at java.lang.Thread.run(Thread.java:745) [na:1.8.0_91]

Regards,
Manojkumar R

On Fri, Nov 11, 2016 at 11:14 AM, Andy LoPresto <alopresto@apache.org>
wrote:

> What is the error you receive in your browser when you try to navigate to
> the UI? Are you connecting to the correct port?
>
> Can you run an OpenSSL s_client command to try to connect via the command
> line? You will need the CA cert, the client certificate, and the client
> private key to attempt the connection below.
>
> $ openssl s_client -connect <host:port> -debug -state -cert
> <path_to_your_cert.pem> -key <path_to_your_key.pem> -CAfile
> <path_to_your_CA_cert.pem>
>
> Are there any errors in $NIFI_HOME/logs/nifi-app.log or
> $NIFI_HOME/logs/nifi-bootstrap.log? Are there any entries in
> $NIFI_HOME/logs/nifi-user.log?
>
> Andy LoPresto
> alopresto@apache.org
> *alopresto.apache@gmail.com <alopresto.apache@gmail.com>*
> PGP Fingerprint: 70EC B3E5 98A6 5A3F D3C4  BACE 3C6E F65B 2F7D EF69
>
> On Nov 10, 2016, at 8:41 PM, Manojkumar Ravichandran <
> sendmailtomj@gmail.com> wrote:
>
> Hi,
>
> Tried to form a secure cluster in nifi 1.0.0 in windows by following the
> instructions from the below link
>
> http://bryanbende.com/development/2016/08/17/apache-nifi-1-
> 0-0-authorization-and-multi-tenancy
>
> It seems like in log file cluster has been formed and heart beats are
> transferring successfully, everything has been settled fine and it shows in
> log file that URL has been launched in the specified port number, but UI is
> not opening in the browser of cluster machines.
>
> To overcome this,I have turned off the firewall settings and but still UI
> is not opening in the borwser
>
> What will be reason for it ?
>
>
> Regards,
>
> Manojkumar R
>
>
>

Mime
View raw message