Hi all,

 

We are currently working on NiFi Hive processors (selectHiveQL, putHiveStreaming…).

 

We are testing them with a CDH platform (and with a “Apache” platform).

 

Hive 1.0.0 is deployed with the last releases of CDH (5.9) while Nifi is built with Hive 1.2.1 libraries.

 

We then have serious compatibility issues. The “simple” selectHiveQL processor fails with “required client_protocol is unset” error message, that seems to shows version mismatch between the hive client and the hive server.

 

Do you know if there are workarounds or solutions for those issues ? I would like to avoid rebuilding NiFi with older libraries.

 

Thanks in advance,

 

BR

 

Nicolas

 

 


Gfi Informatique Telecom
Nicolas Provenzano

BU Telecom / Customer Experience

nicolas.provenzano@gfi.fr 
— 
2 rue Andras Beck – 92360 Meudon La Forêt
Tél. : +33 (0)1 46 83 35 06
Mob. : +33 (0)6 82 07 19 21

www.gfi.world

signature-img