nifi-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bram vd Klinkenberg <Bram_vd_Klinkenb...@hotmail.com>
Subject Re: Access Denied after initial setup
Date Tue, 28 Mar 2017 12:43:53 GMT
Solved it!


I used CN=admin with the toolkit and cn=admin in the users.xml.... Changed this to CN=admin
and works fine now :).



________________________________
Van: Bram vd Klinkenberg
Verzonden: dinsdag 28 maart 2017 12:59
Aan: users@nifi.apache.org
Onderwerp: FW: Access Denied after initial setup


Hi, I have some issues after initial setup and securing NiFi.


I have setup a CentOS6 (including java) machine with hostname nifi.domeinbram.nl.

I downloaded NiFi and the tls toolkit and extracted them to /opt. I ran nifi.sh install and
startedt the nifi service. After the initial setup of NiFi 1.1.2 I can access the UI on port
8080/nifi fine.


I then used the tls-toolkit for securing NiFi:

./tls-toolkit.sh standalone -n 'nifi.domeinbram.nl' -C 'CN=admin' -o keys/

I then copied the new nifi.properties, keystore.jks and truststore.jks to /opt/nifi/conf/.

I imported the CN=admin.p12 into my browser and pasted the password in the CN=admin.password
file and was successfully imported.

In the authorizers.xml I added CN=admin as Initial Admin Identity and CN=nifi.domeinbram.nl
as Node Idenity 1.

I then restarted the nifi service but I get an access denied message.


I added the xml files.

Hope someone can help me out... doing something wrong :).


Kind regards,


Bram


Mime
View raw message