nifi-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Juan Pablo Gardella <gardellajuanpa...@gmail.com>
Subject Re: Cannot convert to timestamp error using putsql processor NiFi 1.3.0
Date Fri, 13 Oct 2017 16:16:53 GMT
I use UpdateAttribute->***->ConvertJSONToSQL->PutSQL

The attribute that is required to be stored as timestamp in DB, I convert
to timestamp at UpdateAttribute. For example:

${myAttribyute:toDate('yyyy-MM-dd'):toNumber()}

Where myAttribute is a string that represents a date. Check
http://apache-nifi-developer-list.39713.n7.nabble.com/PutSQL-error-sql-arg3-value-cannot-convert-to-timestamp-td13271.html
for
more information. It shows some JIRAs fixed in nifi 1.4.0, so this was the
reason I suggested to test at 1.4.0.

To don't fight against formats, I took the approach to convert to timestamp
before putting in DB.

Juan

On Fri, 13 Oct 2017 at 12:21 rakesh <rakesh999.alla@gmail.com> wrote:

> Hi Juan Pablo Gardella,
>
> Thanks for your reply.
> I tried with 1.4.0 as per your suggestion but still same issue.I'm not
> getting any clue of your other suggstion  I tried like
> "${sql.args.28.value:toDate():toNumber()}" like this in Update Attribute
> Processor but didn't work. Could you please explain bit more.
>
>
>
> --
> Sent from: http://apache-nifi-users-list.2361937.n4.nabble.com/
>

Mime
View raw message