nifi-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matt Gilman <matt.c.gil...@gmail.com>
Subject Re: Deep linking doesn’t work in secured NiFi
Date Mon, 09 Oct 2017 14:16:49 GMT
I've responded to your question on SO [1].

Matt

[1] https://stackoverflow.com/a/46648603/5969130

On Mon, Oct 9, 2017 at 1:01 AM, mathes waran <matheskrishna@gmail.com>
wrote:

> Hi Jeff,
>
>
> Thank you for your response.
>
>
> I didn’t configure *SPNEGO*. Even LDAP authentication won’t work for deep
> link access. It navigates to login page and enter root URL after successful
> login.
>
>
> Deep link works fine when no authentication enabled. But it fails when it
> navigates to login page for authentication and then enter to root URL
> instead of actual URL (Selected Processor link).
>
>
> Consider this case and add support for the same if it is valid.
>
>
>
> Regards,
>
> Matheswaran
>
> On Sat, Sep 30, 2017 at 12:41 AM, Jeff <jtswork@gmail.com> wrote:
>
>> Hello Matheswaran,
>>
>> Sorry you're having trouble accessing deep links with secured NiFi.  Have
>> you configured SPNEGO in your browser in order to access the NiFi UI?  I
>> believe, if you've acquired a Kerberos TGT through kinit, and your browser
>> is configured properly for Kerberos/SNPEGO, you should not see a login page
>> when you go to the NiFi UI.
>>
>> If you try to access NiFi via https://host:port/nifi/, are you able to
>> see the root group, or are you redirected to a login page?  If that is the
>> case, you should be able to log in with your Kerberos credentials via the
>> login page, and I think you'll be redirected to the original URL you were
>> attempting to access (even if it's a deep linking URL).
>>
>> If your browser isn't set up for SPNEGO access to the KDC used by NiFi,
>> you will be redirected to the login page.  Once you have configured your
>> browser for SNPEGO and have done a kinit locally, you won't have to log in
>> through the NiFi UI via the login page.
>>
>> Here's a link I found that might help you haven't configured your browser
>> for SPNEGO access to the NiFi UI:  https://ping.force.com/Suppor
>> t/PingFederate/Integrations/How-to-configure-supported-
>> browsers-for-Kerberos-NTLM
>>
>> On Thu, Sep 28, 2017 at 3:04 AM mathes waran <matheskrishna@gmail.com>
>> wrote:
>>
>>>
>>> Hi,
>>>
>>>
>>> Sub: Deep linking doesn’t work in secured NiFi
>>>
>>>
>>>
>>> I have configured NiFi with Kerberos authentication. When I open deep
>>> link to access a processor group, it redirects to login page for
>>> authentication but after successful login, it navigate to root url instead
>>> of that particular processor group.
>>>
>>>
>>>
>>> Jira link found for this support - https://issues.apache.org/jira
>>> /browse/NIFI-3035
>>>
>>>
>>>
>>> But it is not working in secure mode. Is this support added only for
>>> normal mode? How can I achieve this in Kerberos mode?
>>>
>>>
>>>
>>> Thanks,
>>>
>>> Matheswaran.S
>>>
>>
>

Mime
View raw message