nifi-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevin Doran <kdoran.apa...@gmail.com>
Subject Re: Buttons are greyed out when initial admin account logs in
Date Fri, 01 Dec 2017 23:43:41 GMT
Hi Mike,

 

Your authorizers.xml and nifi.properties look correct to me to establish the certificate "CN=admin,
OU=NIFI" as an admin user.

 

Here's one idea that you may have already thought of... the initial admin is only granted
admin policies if users/policies are empty on startup. Try deleting conf/users.xml and conf/authorizations.xml
and restarting NiFi.

 

Hope this helps! If you have any other questions about configuring LDAP or authorizers, let
me know.

 

Kevin

 

 

 

From: Mike Thomsen <mikerthomsen@gmail.com>
Reply-To: <users@nifi.apache.org>
Date: Friday, December 1, 2017 at 18:27
To: <users@nifi.apache.org>
Subject: Buttons are greyed out when initial admin account logs in

 

I'm following Pierre's blog post that shows how to set up LDAP w/ ApacheDS:

https://pierrevillard.com/2017/01/24/integration-of-nifi-with-ldap

I've tried this with 1.4.0 and 1.5.0-SNAPSHOT (toolkits built for each too) for what it's
worth.

Built the certs with this command:

bin/tls-toolkit.sh standalone -n localhost -C "CN=admin,OU=NIFI" -O -o ../security_output

Copied security_output/localhost/* to $NIFI_ROOT/conf

With or without the identity provider set to use the LDAP configuration, it's greyed out.

 

Any ideas on what I'm doing wrong?

 

Thanks,

 

Mike


Mime
View raw message