nifi-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Scott Howell <scotthow...@mobilgov.com>
Subject Re: Cluster coordinator does not update cluster subdomain when new node states up
Date Thu, 05 Apr 2018 18:00:42 GMT
I was not able to find any place where that previous node is in the properties files. I rebuilt
the cluster from scratch using my Ansible playbook so I updated all the areas there and reconfigured
brand new servers. I had this problem once before previously and just bringing up brand new
servers seemed to fix it but that hasn’t worked this time.



> On Apr 5, 2018, at 11:12 AM, Andy LoPresto <alopresto@apache.org> wrote:
> 
> Hi Scott,
> 
> Can you check the contents of your nifi.properties (specifically the nifi.cluster.* and
nifi.zookeeper.* sections) as well as the conf/zookeeper.properties files on each node in
the cluster to see if one still has the old address?
> 
> Andy LoPresto
> alopresto@apache.org <mailto:alopresto@apache.org>
> alopresto.apache@gmail.com <mailto:alopresto.apache@gmail.com>
> PGP Fingerprint: 70EC B3E5 98A6 5A3F D3C4  BACE 3C6E F65B 2F7D EF69
> 
>> On Apr 5, 2018, at 9:50 AM, Scott Howell <scotthowell@mobilgov.com <mailto:scotthowell@mobilgov.com>>
wrote:
>> 
>> I had to change the subdomain of my cluster nodes. The cluster node names are nifi-{#}.internal.dev.{redacted}.com.
Looking at my log below it still believes there is a cluster coordinator is found at nifi-2.dev.{redacted}.com.

>> 
>> o.a.n.c.c.node.NodeClusterCoordinator Failed to determine which node is elected active
Cluster Coordinator: ZooKeeper reports the address as nifi-2.dev.{redacted}.com:9999, but
there is no node with this address. Attempted to determine the node's information but failed
to retrieve its information due to org.apache.nifi.cluster.protocol.ProtocolException: Failed
to create socket due to: java.net.UnknownHostException: nifi-2.dev.{redacted}.com
>> 
>> I had this problem before and just completely rebuilt the cluster, I did this, this
time and that doesn’t seem to be working. If anyone has any insight that would be great.
>> 
>> Thanks,
>> 
>> Scott
> 


Mime
View raw message