nifi-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From William Gosse <William.Go...@aifoundry.com>
Subject RE: NiFi 1.7.1 remote group not connecting when added through restful api until nifi restarted
Date Thu, 15 Nov 2018 17:03:18 GMT
I don't believe I see any error messages on the initial remote process group that gets created.

I do see the error message when I do a restart and there are existing remote process groups
but they do seem to connect eventually

It's only the initial create of  the first remote process group that seems to be acting weird.

-----Original Message-----
From: Koji Kawamura <ijokarumawak@gmail.com> 
Sent: Thursday, November 15, 2018 1:05 AM
To: users@nifi.apache.org
Subject: Re: NiFi 1.7.1 remote group not connecting when added through restful api until nifi
restarted

[CAUTION: This email originated from outside of Kodak Alaris. Do not click links or open attachments
unless you recognize the sender and know the content is safe.] ________________________________

Hello William,

> fails to connect to the existing input port until I do a restart of 
> NiFi
Is there any error message when it fails? Connection refused?
It should not require a NiFi restart to establish connection.

Thanks,
Koji



On Thu, Nov 15, 2018 at 1:38 AM William Gosse <William.Gosse@aifoundry.com> wrote:
>
> I'm using NiFi's restful api to create a process group from a template 
> that contains a file folder listener and a remote group. I also have 
> an existing input port going to a process group that has the file 
> fetch and everything else for processing the file that was fetched. 
> This is not added by a restful api but is loaded from a template after 
> the initial startup of Nifi. What I wind up with is a list fetch 
> pattern that should cluster ready/
>
> My problem is that the first time I use the rest api to add the listener process group
the remote group that's inside of it fails to connect to the existing input port until I do
a restart of NiFi. At that point all subsequent listeners I add seem to connect just fine.
>
> Is there way that I can cause the initial connection to occur without having to perform
a restart?
>
>
Mime
View raw message