nifi-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Payne <marka...@hotmail.com>
Subject Re: NiFi 1.8 and stuck flowfile in Load Balanced enabled queue
Date Fri, 16 Nov 2018 14:04:52 GMT
Hey Josef,

So a few questions to help figure out what's going on here:

- What is the Load Balance Strategy in use? (I.e., Round Robin, Partition by Attribute, etc.)
- What compression is being used (None, Compress Attributes Only, Compress Contents and Attributes)
- How many nodes in the cluster?
- Are all nodes connected?
- What is the backpressure configured to?

Is the source or destination of the Connection a Processor? If so, we can get a lot of info
by going to

http://localhost:8080/nifi-api/processors/<processor id>/diagnostics

Where http://localhost:8080/ would need to be changed to wherever your nifi instance is running
and
<processor id> is the UUID of the Processor that is either the source or destination
of the connection.
You can get the UUID of the Processor by clicking on it in the UI and then looking at the
'Operate' palette
on the left-hand side of the screen. If you can get the result of going to the URL, it will
likely be helpful,
as it shows a lot of details about the processor, as well as all of its incoming and outgoing
connections.

Thanks
-Mark



On Nov 16, 2018, at 3:05 AM, <Josef.Zahner1@swisscom.com<mailto:Josef.Zahner1@swisscom.com>>
<Josef.Zahner1@swisscom.com<mailto:Josef.Zahner1@swisscom.com>> wrote:

Hi Mark

We see the issue again, even after a fresh started cluster (where we started everything at
the same time). The files stuck for multiple seconds/minutes in the queue and the light blue
loadbalancing icon on the right side shows that it is actually loadbalancing the whole time
(even if it is just 1 or 2 files). The log (with default log levels) show no WARN or ERRORs…

Thanks in advance, Josef


From: Mark Payne <markap14@hotmail.com<mailto:markap14@hotmail.com>>
Reply-To: "users@nifi.apache.org<mailto:users@nifi.apache.org>" <users@nifi.apache.org<mailto:users@nifi.apache.org>>
Date: Monday, 12 November 2018 at 17:19
To: "users@nifi.apache.org<mailto:users@nifi.apache.org>" <users@nifi.apache.org<mailto:users@nifi.apache.org>>
Subject: Re: NiFi 1.8 and stuck flowfile in Load Balanced enabled queue

Hey Dan,

Have looked through the logs to see if there are any WARN or ERROR's indicating what's going
on?

Thanks
-Mark



On Nov 12, 2018, at 9:06 AM, dan young <danoyoung@gmail.com<mailto:danoyoung@gmail.com>>
wrote:

Hello,

We have two processor groups connected via the new  Load Balancing/Round Robin queue.  It
seems that a flowfile is "stuck" in this queue.  I've been watching it for some time now.
 Is there any way to trouble shoot what is stuck in the queue and why?  or maybe remove it?
 I've tried to stop the PG and empty the queue, but always says emptied 0 out of 1 flowflies...

Regards,

Dano



<Screen Shot 2018-11-12 at 7.00.37 AM.png>

Mime
View raw message