nifi-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bryan Bende <bbe...@gmail.com>
Subject Re: process group name reverts back to initial value if I do a nifi registry "Change version"
Date Tue, 08 Jan 2019 17:58:44 GMT
I will keep trying, but I haven't been able to reproduce using NiFi
1.8.0 and registry 0.2.0.

I must be missing something.

On Tue, Jan 8, 2019 at 11:50 AM <Josef.Zahner1@swisscom.com> wrote:
>
> I've tried it now on another secured cluster exactly like you did:
>
>         1) Create PG "A" and save to registry
>         2) Import PG "A" from registry and rename to "B"
>         3) Add new processor (Execute Script) to original PG "A" and save to registry
>         4) Change version on PG "B" to new version
>
> Problem still there... after changing to new version on "B" the name changed back to
"A"
>
>
>
> On 08.01.19, 17:40, "Zahner Josef, GSB-LR-TRW-LI" <Josef.Zahner1@swisscom.com>
wrote:
>
>     Hi Bryan
>
>     In my case it happens all the time, doesn't matter what kind of change. On my first
test below I've changed a variable on a processor inside the PG and the second time (a few
seconds ago) I've added a connection to my "Execute Script" processor. All the time my second
PG with the new name changed back to the initial name... Even if I just click "Change version"
and select another one than the current, my second PG changes the name back to the initial
value.
>
>     Btw. we use NiFi Registry 0.2.0.
>
>     Cheers Josef
>
>
>
>
>
>     On 08.01.19, 17:23, "Bryan Bende" <bbende@gmail.com> wrote:
>
>         Hi Josef,
>
>         That sounds like a possible bug. I think the PG name is supposed to
>         remain unchanged.
>
>         I wasn't able to reproduce this though... in step 5 when you change
>         the "abc" group, what type of change are you making?
>
>         I did the following...
>
>         1) Create PG "A" and save to registry
>         2) Import PG "A" from registry and rename to "B"
>         3) Add new processor to original PG "A" and save to registry
>         4) Change version on PG "B" to new version
>
>         PG "B" is still named "B" at this point.
>
>         On Tue, Jan 8, 2019 at 10:26 AM <Josef.Zahner1@swisscom.com> wrote:
>         >
>         > Hi guys
>         >
>         >
>         >
>         > I’ve faced again an (at least for me) unexpected behavior of NiFi 1.8.0
together with NiFi Registry.
>         >
>         >
>         >
>         > Following use case:
>         >
>         >
>         >
>         > Create a process group with name “abc” and add some processors to the
pg
>         > Commit the pg to the NiFi registry
>         > Create a new pg and import the pg from step 1 from the registry
>         > Change the name of the new pg to “def” instead of “abc” – so far
so good, no change from registry point of view
>         > Change the original pg “abc” from step 1 and commit the change to the
registry
>         > Now we have change to the newest version for the pg “def” from step
4, as it isn’t anymore up to date – but now in my case as soon as I’m changing the version,
the pg name gets changed back to “abc”. This happens all the time if I change the version
on a pg which has another name than on the commit
>         >
>         >
>         >
>         > Any comments on this? We use the NiFi registry as well as templating infrastructure,
means we have several times the same pg but with different variables and names on the same
NiFi canvas. But with the actual behavior this is very inconvenient… we have to memorize
the name before we do the “Change version” and then after execution we have to set it
again.
>         >
>         >
>         >
>         > Cheers Josef
>
>
>
>

Mime
View raw message