nifi-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aldrin Piri <aldrinp...@gmail.com>
Subject Re: High CPU consumption
Date Mon, 14 Oct 2019 01:03:55 GMT
HI Luis,

It is not likely to be the logging.  The area you have highlighted is just
the associated jars included for the classpath.

Profiling could be an option if you are familiar but the community could
also assist effectively if you are able to share a template of your flow (
https://nifi.apache.org/docs/nifi-docs/html/user-guide.html#templates) or
at least talk about the components you are using and their configuration.



On Sun, Oct 13, 2019 at 8:58 PM Luis Carmona <lcarmona@openpartner.cl>
wrote:

> hi Aldrin,
>
> thanks a  lot, by now I'm trying to learn how to make the profiling you
> mentioned.
>
> One more question: Is it normal that the father java process has very low
> consumption while the child process related to logback jar is the one that
> is eating up all the CPU ?
> Please take a look at the attached image.
>
> Thanks,
>
> LC
>
> ------------------------------
> *From: *"Aldrin Piri" <aldrinpiri@gmail.com>
> *To: *"users" <users@nifi.apache.org>
> *Sent: *Sunday, October 13, 2019 9:30:47 PM
> *Subject: *Re: High CPU consumption
>
> Luis, please feel free to give us some information on your flow so we can
> help you track down problematic areas as well.
>
> On Sun, Oct 13, 2019 at 3:56 PM Jon Logan <jmlogan@buffalo.edu> wrote:
>
>> You should put a profiler on it to be sure.
>> Just because your processors aren't processing data doesn't mean they are
>> idle though -- many have to poll for new data, especially sources -- ex.
>> connecting to Kafka, etc, will itself consume some CPU.
>>
>> But again, you should attach a profiler before participating in a wild
>> goose chase of performance issues.
>>
>> On Sun, Oct 13, 2019 at 12:20 PM Luis Carmona <lcarmona@openpartner.cl>
>> wrote:
>>
>>> HI,
>>>
>>> I've struggling to reduce my nifi installation CPU consumption. Even in
>>> idle state, all processors running but no data flowing, it is beyond 60%
>>> CPU consumption, with peaks of 200%.
>>>
>>> What I've done so far
>>> - Read and followed every instruction/post about tuning NIFI I've found
>>> googling.
>>> - Verify scheduling is 1s for most consuming processors: http
>>> processors, wait/notify, jolt, etc.
>>> - Scratch my head...
>>>
>>> But nothing seems to have a major effect on the issue.
>>>
>>> Can anyone give me some precise directions or tips about how to solve
>>> this please ?
>>> Is this the regular situation, I mean this is the minimun NIFI
>>> consumption.
>>>
>>> The server is configure with 4 CPU's, 8 GB RAM - 4 of them dedicated to
>>> heap at bootstrap.conf.
>>>
>>> Thanks in advance.
>>>
>>> LC
>>>
>>
>

Mime
View raw message