nutch-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrzej Bialecki ...@getopt.org>
Subject Re: Build.xml's symlink not working on CygWin [jira offline?]
Date Fri, 03 Jun 2005 10:55:58 GMT
Dawid Weiss wrote:
> 
> Hi there,
> 
> JIRA seems to be offline, so here:
> 
> My CygWin installation reports an error when running a repeated 'ant 
> jar' -- symlink fails with:
> 
> jar:
>   [symlink] ln -s ./build/nutch-0.7-dev.jar D:\nutch\nutch\trunk/nutch.jar
>   [symlink] ln: `D:\\nutch\\nutch\\trunk/nutch.jar': File exists
> 
> A quick and dirty hack is to attempt to delete the link:
> 
> $ svn diff build.xml
> Index: build.xml
> ===================================================================
> --- build.xml   (revision 179742)
> +++ build.xml   (working copy)
> @@ -101,6 +101,7 @@
>        jarfile="${build.dir}/${final.name}.jar"
>        basedir="${build.classes}"
>      />
> +    <delete failonerror="false" file="${basedir}/${name}.jar.lnk" />
>      <symlink overwrite="true" link="${basedir}/${name}.jar"
>               resource="${build.dir}/${final.name}.jar"/>
>    </target>
> 
> Is anyone having the same issue?
> 
> Dawid
> 
> 

Same here. I don't think using symlinks on Windows is a good idea. I 
think this should be replaced by a copy.


-- 
Best regards,
Andrzej Bialecki     <><
  ___. ___ ___ ___ _ _   __________________________________
[__ || __|__/|__||\/|  Information Retrieval, Semantic Web
___|||__||  \|  ||  |  Embedded Unix, System Integration
http://www.sigram.com  Contact: info at sigram dot com


Mime
View raw message