nutch-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Strittmatter, Stephan" <>
Subject Naming of lib-plugins, was: AW: MS related plugins refactoring
Date Tue, 06 Sep 2005 09:22:50 GMT

> Here is a copy of my previous mail, if someone want to comment it:
> I have just committed some modifications that enable to have some
> dependencies between plugins.
> I would like to apply this mechanism to parse-ms* related plugins that both
> uses jakarta poi code.
> The idea is: instead of duplicating jakarta poi related jar in each lib
> directory of parse-ms* plugins,
> I would like to :
> * create a poi plugin that contains these jar files,
> * and to specify that the parse-ms* plugins depends (requires) the poi plugin.
> What do you think about it?
> What plugin name do you suggest for the poi plugin (simply poi, or something
> like jakarta-poi or lib-poi ?)
I think pre-fixing the plugin with "lib-" is a good idea to seperate such plugins from "index-",
"parse-" etc. 
Because of that I would prefer a name like "lib-jakarta-poi".
BTW, what do you think about adding more into to the lib-plugins like the location of the
license and the 
download location of the libs? Just an idea...


  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message