nutch-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Piotr Kosiorowski <pkosiorow...@gmail.com>
Subject Re: PMD integration
Date Sun, 09 Apr 2006 19:15:05 GMT
Jérôme Charron wrote:
> 2) We do have oro 2-0.7 in dependencies (I think urlfilter and similar
>> things). PMD requires oro - 2.0.8. Do you think we can upgrade (as far
>> as I know 2.0.7 and 2.0.8 should be compatible)? We would have only one
>> oro jar than.
> 
> Piotr, please keep oro-2.0.8 in pmd-ext
> I think we can plan to replace oro regex by java ones (as in RegexUrlFilter)
> in the whole nutch code (and then remove oro-2.0.7 from lib):
> src/plugin/index-more/src/java/org/apache/nutch/indexer/more/MoreIndexingFilter.java
> src/plugin/parse-js/src/java/org/apache/nutch/parse/js/JSParseFilter.java
> src/java/org/apache/nutch/parse/OutlinkExtractor.java
> src/java/org/apache/nutch/net/RegexUrlNormalizer.java
> src/java/org/apache/nutch/net/BasicUrlNormalizer.java
> 

I do not agree here - we are going to make a new release next week and 
releasing with two versions of oro does not look nice. oro is quite 
stable product and changes are in fact minimal:
http://svn.apache.org/repos/asf/jakarta/oro/trunk/CHANGES
I would like to upgrade to 2.0.8 (as no interface changes were made it 
would be trivial) before 0.8 release.
What do others think?
Regards
Piotr


Mime
View raw message