nutch-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrzej Bialecki ...@getopt.org>
Subject Re: Nutch requires JDK 1.5 now?
Date Tue, 03 Oct 2006 15:38:25 GMT
Chris Mattmann wrote:
> Hi Folks,
>
>  I noticed that Nutch now requires JDK 5 in order to compile, due to recent
> changes to the PluginRepository and some other classes. I think that this is
> a good move, however, I wasn't sure that I had seen any "official"
> announcement that Nutch now requires 1.5...
>   

This is a proactive change - as soon as we upgrade to Hadoop 0.6.x we 
will lose 1.4 compatibility anyway, so we may as well prepare in advance.

Also, "Now" refers to the unreleased 0.9, we will keep branch 0.8.x  
compatible with 1.4.

-- 
Best regards,
Andrzej Bialecki     <><
 ___. ___ ___ ___ _ _   __________________________________
[__ || __|__/|__||\/|  Information Retrieval, Semantic Web
___|||__||  \|  ||  |  Embedded Unix, System Integration
http://www.sigram.com  Contact: info at sigram dot com



Mime
View raw message