nutch-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Julien Nioche <lists.digitalpeb...@gmail.com>
Subject Re: Upgrade to hadoop 0.20?
Date Wed, 16 Sep 2009 13:34:06 GMT
Hi,

Resurrecting an old thread... Just had a look at Hadoop 0.20.1 and it looks
like it does have MapFileOutputFormat (package org.apache.hadoop.mapred) -
apart from a few errors for which I will throw a JIRA shortly, it compiled
fine.
Would it be worth upgrading to 0.20.1 in order to benefit from the latest
improvements and bugfixes of Hadoop? We can then move the code to the new
API progressively.

What do you think?

J.

2009/7/9 Doğacan Güney <dogacan@gmail.com>

> On Wed, Jul 8, 2009 at 11:13, Julien Nioche <lists.digitalpebble@gmail.com
> > wrote:
>
>> Good idea.
>
>
> OK, it turns out that we can't :D.
>
> MapFileOutputFormat (which we use heavily) is not yet upgraded to hadoop
> 0.20. We can start using hadoop 0.20 but since we have to use old deprecated
> APIs, it doesn't make much sense to me.
>
>
>>
>>
>> 2009/7/8 Doğacan Güney <dogacan@gmail.com>
>>
>> Hey list,
>>>
>>> Does anyone have any objections to upgrading to hadoop 0.20? As you may
>>> know, they have completely
>>> overhauled the MapReduce API(they still keep old API around but it is
>>> deprecated). There is a lot of mundane
>>> work to do to change all our MR code to new API but I can do that.
>>>
>>> So what do you guys think?
>>>
>>> --
>>> Doğacan Güney
>>>
>>
>>
>>
>> --
>> DigitalPebble Ltd
>> http://www.digitalpebble.com
>>
>
>
>
> --
> Doğacan Güney
>



-- 
DigitalPebble Ltd
http://www.digitalpebble.com

Mime
View raw message