nutch-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Julien Nioche (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (NUTCH-983) Upgrade SolrJ
Date Wed, 04 May 2011 20:40:03 GMT

    [ https://issues.apache.org/jira/browse/NUTCH-983?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13028945#comment-13028945
] 

Julien Nioche commented on NUTCH-983:
-------------------------------------

The only explanation I can think of is that we are getting these from some second hand dependencies
which for some reason must be excluded in the trunk.

Adding them as global exclusion seems to do the trick : 

{code:xml}

            <!--global exclusion-->
             	<exclude module="jmxtools" />
             	<exclude module="jms" />
             	<exclude module="jmxri" />
	</dependencies>
{code} 

Since all we need is the SOLRJ library, these jars should not be necessary at all. 




> Upgrade SolrJ
> -------------
>
>                 Key: NUTCH-983
>                 URL: https://issues.apache.org/jira/browse/NUTCH-983
>             Project: Nutch
>          Issue Type: Improvement
>          Components: indexer
>    Affects Versions: 1.3, 2.0
>            Reporter: Markus Jelsma
>            Priority: Minor
>             Fix For: 1.3, 2.0
>
>
> Solr 3.1 has been released a while ago. The Javabin format between 1.4.1 and 3.1 has
been changed so our SolrJ 1.4.1 cannot send documents to 3.1. Since Nutch 2.0 won't be released
within a short period i believe it would be a good idea to upgrade our SolrJ to 3.1. New Solr
users are encouraged to use Solr 3.1 or upgrade so i expect more users wanting to use 3.1
as well. Any thoughts?

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message