nutch-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lewis John McGibbney (Updated) (JIRA)" <>
Subject [jira] [Updated] (NUTCH-1218) Improve trunk API documentation
Date Tue, 13 Dec 2011 22:31:30 GMT


Lewis John McGibbney updated NUTCH-1218:

    Attachment: NUTCH-1218.patch

This patch is a work in progress. So far it includes the following
1) Covers half of the core packages by substantiating on the minimal package.html descritpions.
2) Fixes the issue with the ${Name} variable which was incorrectly specified
3) Adds missing plugins to the Javadoc Ant target in build.xml.

There is an issue I have stumbled across, can anyone explain in, why there
is a _*:\_ after some plugin class names when there is not this after others?

# Parse Plugins


> Improve trunk API documentation
> -------------------------------
>                 Key: NUTCH-1218
>                 URL:
>             Project: Nutch
>          Issue Type: Sub-task
>          Components: documentation
>    Affects Versions: 1.4
>            Reporter: Lewis John McGibbney
>            Assignee: Lewis John McGibbney
>             Fix For: 1.5
>         Attachments: NUTCH-1218.patch
> The trunk API Java documentation could do with some improving. This issue should track
that. It should however not seek to change any functionality within the codebase, only to
substantiate and improve the existing documentation.  

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


View raw message