nutch-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sebastian Nagel <wastl.na...@googlemail.com>
Subject Re: upgrading protocol-httpclient to httpclient 4.1.1
Date Fri, 04 Apr 2014 20:28:41 GMT
Hi,

does it mean you are (also) addressing NUTCH-1086? Would be great,
since this issue is waiting for a solution since long!

> The reason I picked version 4.1.1 and not the latest is because I noticed
> it is already in the build/lib dir and I wasn't sure I can use two versions
> of the jar with the same namespace without creating conflicts.

You should be able to use any version of httpclient, but it must be
registered as dependency in the plugin's ivy.xml (src/plugin/protocol-httpclient/ivy.xml),
not in the "main" ivy/ivy.xml.

Each plugin gets its own class loader to solve the problem of conflicting
dependencies, see
https://wiki.apache.org/nutch/WhatsTheProblemWithPluginsAndClass-loading

I didn't check 2.2.1, but in head of 2.x httpclient 4.2.6 is a dependency
of a dependency (solrj) of the indexer-solr plugin. The upgrade has been done
with NUTCH-1568.

Sebastian

On 04/04/2014 04:14 PM, d_k wrote:
> I've written a patch for the 2.2.1 source code that upgrades the
> protocol-httpclient to httpclient 4.1.1
> 
> Unfortunately I had to adjust the test because currently httpclient 4.1.1
> does not support authenticating with different credentials against
> different realms in the same domain:
> HTTPCLIENT-1490<https://issues.apache.org/jira/browse/HTTPCLIENT-1490>
> .
> 
> The reason I picked version 4.1.1 and not the latest is because I noticed
> it is already in the build/lib dir and I wasn't sure I can use two versions
> of the jar with the same namespace without creating conflicts.
> 
> My questions are:
> 1) Anyone needs this patch or did I took the wrong path in choosing 4.1.1?
> 2) If so, under what JIRA issue should I submit it? NUTCH-751? NUTCH-1086?
> something else? new issue?
> 


Mime
View raw message